php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38615 appendXML with xml:id crashes PHP
Submitted: 2006-08-27 13:46 UTC Modified: 2006-08-28 10:07 UTC
From: dave at dgx dot cz Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 5.1.5 OS:
Private report: No CVE-ID: None
 [2006-08-27 13:46 UTC] dave at dgx dot cz
Description:
------------
self-explaining code snippet:


$dom = new DOMDocument();
$dom->loadXML('<xml></xml>');

$frag = $dom->createDocumentFragment();
$frag->appendXML('<span xml:id="a"></span>');

// this crashes PHP (cli) 5.1.2 - 5.1.6
$dom->createTextNode("xxxxxxxxxxxxxxxx");



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-27 14:17 UTC] bjori@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

Can't reproduce...
 [2006-08-27 17:14 UTC] dave at dgx dot cz
I've got the same problem with php5.2-win32-latest. Tested with CLI and Apache 2
 [2006-08-27 22:21 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

I've tried the most recent CVS snapshot and the above shown 
PHP script does not crash or raise any errors.
 [2006-08-28 10:07 UTC] rrichards@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

libxml problem. newer versions (looks like .24+) will at least mask the problem and not cause crash with example code. Current work around is to not use xml namespace anywhere within fragment.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 02:01:23 2020 UTC