php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38612 Oracle retrieval of LOBs broken
Submitted: 2006-08-27 01:27 UTC Modified: 2006-08-28 23:01 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: stronk7 at moodle dot org Assigned:
Status: Closed Package: OCI8 related
PHP Version: 5.1.5 OS: MacOS X and Linux
Private report: No CVE-ID: None
 [2006-08-27 01:27 UTC] stronk7 at moodle dot org
Description:
------------
Under PHP 5.1.x, retrieval of LOBs is completely broken. We 
have tried it with:

ocifetchinto() with the OCI_RETURN_LOBS flag set.
ociloadlob()
OCI-Lob->read()
OCU-Lob->load()

and the script ends with timeout.

It seems that this bug was solved in Bug 37406 and closed 
for 5.1.4 but under 5.1.6 the same problem persists.

Isn't this going to be back-ported to 5.1.x series? It does 
Oracle practically unusable!

Ciao, Eloy :-)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-28 06:20 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-08-28 18:22 UTC] stronk7 at moodle dot org
I've just executed my test with php5.2-200608281430 and clob 
info (with OCI_RETURN_LOBS enabled) seems to be being fetched 
properly with that PHP version (under Linux and MacOS X).
 [2006-08-28 18:48 UTC] tony2001@php.net
Great, then please install OCI8 from PECL (the latest OCI8 release is equal to 5.2-CVS).
 [2006-08-28 23:01 UTC] stronk7 at moodle dot org
Tested. PHP 5.1.6 + OCI8 1.2.2 seems to work properly with 
LOBs.

Thanks and ciao :-)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 15:01:24 2021 UTC