php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #38519 support charspacing in imagefttext()
Submitted: 2006-08-20 09:21 UTC Modified: 2016-09-14 16:13 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: wkpark at kldp dot org Assigned: cmb (profile)
Status: Duplicate Package: GD related
PHP Version: 5.1.5 OS: Linux
Private report: No CVE-ID: None
 [2006-08-20 09:21 UTC] wkpark at kldp dot org
Description:
------------
currently imagefttext() support linespacing but charspacing does not.

charspacing is particularly important for CJK fonts.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-20 09:41 UTC] wkpark at kldp dot org
this is a patch made by hjsong and J.
and it works fine for me :)

http://chem.skku.ac.kr/~wkpark/linux/patch/php5.x-gd-charspacing.patch
 [2010-12-20 14:17 UTC] jani@php.net
-Package: Feature/Change Request +Package: GD related
 [2016-09-14 14:01 UTC] cmb@php.net
-Status: Assigned +Status: Duplicate -Assigned To: pajoye +Assigned To: cmb
 [2016-09-14 14:01 UTC] cmb@php.net
This is a duplicate of request #27617. Unfortunately, the patch
isn't available anymore.
 [2016-09-14 14:15 UTC] requinix@php.net
archive.org managed to grab a copy of the patch back in 2007.
http://web.archive.org/web/20070429071227/http://chem.skku.ac.kr/~wkpark/linux/patch/php5.x-gd-charspacing.patch
Looks like fairly straightforward changes.
 [2016-09-14 16:13 UTC] cmb@php.net
Thanks for digging out the patch!

> Looks like fairly straightforward changes.

I expected as much. :-) However, the problem is that the patch
would need to be applied to external libgd also, and currently
gdft.c of external and bundled libgd are rather out of sync, what
ideally should be fixed first, before more features are added. See
<https://github.com/php/php-src/pull/1845#issuecomment-234579343>.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 11:01:26 2019 UTC