php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38514 5.1RC5 has troubles with Zlib which 5.1RC4 not have
Submitted: 2006-08-19 23:07 UTC Modified: 2008-09-22 11:33 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: cweiske at cweiske dot de Assigned: sfox (profile)
Status: Closed Package: PHP-GTK related
PHP Version: 5.1.4 OS: win xp
Private report: No CVE-ID: None
 [2006-08-19 23:07 UTC] cweiske at cweiske dot de
Description:
------------
First problem is that in ythe GTK+-Packages there is no "intl.dll", i found a working in the web while the one that is provided by "MySQL Administrator" did not work.

--

Now the php_gtk2.dll loads but on every script-call even a "php -v" errors like the following will be shown 

"Strict Standards: Declaration of GtkToolbar::set_style() should be compatible with that of GtkWidget::set_style()"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-20 07:37 UTC] cweiske@php.net
You have E_STRICT settings activated. PHP-Gtk2 currently is not compatible with this setting.
 [2006-08-20 08:20 UTC] sfox@php.net
There's no intl.dll because when I tested the dependencies for the GTK runtime package intl.dll didn't come up as being one of them. I'll re-test and try to establish why, but in the meantime could you please tell me how you came to the conclusion there was a missing dependency? (Was there an error message for example?)

Those errors aren't down to E_STRICT being enabled, they're down to display_startup_errors being turned on. Outside of that, E_STRICT is fine (in fact I develop with E_STRICT enabled too). 

I have already discussed the startup errors at some length with Andrei, Dmitry Stogov and Andi Gutmans on the PHP internals list, because it's down to the way internal object inheritance is defined in the Zend Engine now. Dmitry advised me that the patch I offered at the time (or any other fix) would NOT be applied because the existing definition is correct for PHP internal objects, and it's not PHP's problem if third-party objects don't adhere to that definition. So this part of the two-part bug report is likely to be a 'won't fix', unless Andrei comes up with some cute way to force GTK objects to comply with PHP inheritance rules. 

Just turn display_startup_errors off. It's off by default anyway.

- Steph
 [2006-08-20 08:25 UTC] cweiske@php.net
The warning:
> "Strict Standards: Declaration of GtkToolbar::set_style() 
> should be compatible with that of GtkWidget::set_style()"
*is* down to E_STRICT standards, and we already discussed this issue on the list.
 [2006-08-20 08:34 UTC] sfox@php.net
Christian - this is not an appropriate forum in which to start a debate. Please stick to the dev list if you want to challenge our assessment of the problem (that's mine and Andrei's).
 [2008-09-22 11:33 UTC] auroraeosrose@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Since 2.0.0 this is no longer an issue - windows releases have the appropriate dlls and the toolbar set_style was renamed to avoid conflicts
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jan 17 04:03:36 2022 UTC