php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38467 --enable-versioning causes make fail when building against apxs2
Submitted: 2006-08-15 15:28 UTC Modified: 2006-08-15 20:14 UTC
From: contax at phrenetic dot org Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.2-200608151630 OS: Darwin Kernel Version 8.7.1
Private report: No CVE-ID:
 [2006-08-15 15:28 UTC] contax at phrenetic dot org
Description:
------------
When building php against apxs2 (Apache 2.2.3) on Mac OS X (10.4.7) the make failes. It works fine when --enable-versioning is left out.

Reproduce code:
---------------
./configure --with-apxs2=/usr/local/apache2/bin/apxs --prefix=/usr/local --enable-versioning

Expected result:
----------------
All compiled

Actual result:
--------------
/bin/sh /Users/contax/src/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/standard/ -I/Users/contax/src/php-5.1.4/ext/standard/ -DPHP_ATOM_INC -I/Users/contax/src/php-5.1.4/include -I/Users/contax/src/php-5.1.4/main -I/Users/contax/src/php-5.1.4 -I/usr/include/libxml2 -I/Users/contax/src/php-5.1.4/ext/date/lib -I/Users/contax/src/php-5.1.4/TSRM -I/Users/contax/src/php-5.1.4/Zend  -no-cpp-precomp  -I/usr/include -g -O2  -c /Users/contax/src/php-5.1.4/ext/standard/info.c -o ext/standard/info.lo 
/Users/contax/src/php-5.1.4/ext/standard/info.c: In function 'php_info_write_wrapper':
/Users/contax/src/php-5.1.4/ext/standard/info.c:69: warning: pointer targets in passing argument 1 of 'php_escape_html_entities' differ in signedness
/Users/contax/src/php-5.1.4/ext/standard/info.c: In function 'php_info_html_esc':
/Users/contax/src/php-5.1.4/ext/standard/info.c:218: warning: pointer targets in passing argument 1 of 'php_escape_html_entities' differ in signedness
/Users/contax/src/php-5.1.4/ext/standard/info.c: In function 'php_print_info':
/Users/contax/src/php-5.1.4/ext/standard/info.c:508: warning: pointer targets in passing argument 3 of 'zend_hash_get_current_key_ex' differ in signedness
/Users/contax/src/php-5.1.4/ext/standard/info.c:539: warning: pointer targets in passing argument 3 of 'zend_hash_get_current_key_ex' differ in signedness
/Users/contax/src/php-5.1.4/ext/standard/info.c:580: warning: pointer targets in passing argument 3 of 'zend_hash_get_current_key_ex' differ in signedness
/bin/sh /Users/contax/src/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -I/usr/local/apache2/include  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -I/usr/local/apache2/include   -I/usr/local/apache2/include  -Isapi/apache2handler/ -I/Users/contax/src/php-5.1.4/sapi/apache2handler/ -DPHP_ATOM_INC -I/Users/contax/src/php-5.1.4/include -I/Users/contax/src/php-5.1.4/main -I/Users/contax/src/php-5.1.4 -I/usr/include/libxml2 -I/Users/contax/src/php-5.1.4/ext/date/lib -I/Users/contax/src/php-5.1.4/TSRM -I/Users/contax/src/php-5.1.4/Zend  -no-cpp-precomp  -I/usr/include -g -O2  -c /Users/contax/src/php-5.1.4/sapi/apache2handler/mod_php5.c -o sapi/apache2handler/mod_php5.lo 
/bin/sh /Users/contax/src/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -I/usr/local/apache2/include  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -I/usr/local/apache2/include   -I/usr/local/apache2/include  -Isapi/apache2handler/ -I/Users/contax/src/php-5.1.4/sapi/apache2handler/ -DPHP_ATOM_INC -I/Users/contax/src/php-5.1.4/include -I/Users/contax/src/php-5.1.4/main -I/Users/contax/src/php-5.1.4 -I/usr/include/libxml2 -I/Users/contax/src/php-5.1.4/ext/date/lib -I/Users/contax/src/php-5.1.4/TSRM -I/Users/contax/src/php-5.1.4/Zend  -no-cpp-precomp  -I/usr/include -g -O2  -c /Users/contax/src/php-5.1.4/sapi/apache2handler/sapi_apache2.c -o sapi/apache2handler/sapi_apache2.lo 
/bin/sh /Users/contax/src/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -I/usr/local/apache2/include  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -I/usr/local/apache2/include   -I/usr/local/apache2/include  -Isapi/apache2handler/ -I/Users/contax/src/php-5.1.4/sapi/apache2handler/ -DPHP_ATOM_INC -I/Users/contax/src/php-5.1.4/include -I/Users/contax/src/php-5.1.4/main -I/Users/contax/src/php-5.1.4 -I/usr/include/libxml2 -I/Users/contax/src/php-5.1.4/ext/date/lib -I/Users/contax/src/php-5.1.4/TSRM -I/Users/contax/src/php-5.1.4/Zend  -no-cpp-precomp  -I/usr/include -g -O2  -c /Users/contax/src/php-5.1.4/sapi/apache2handler/apache_config.c -o sapi/apache2handler/apache_config.lo 
/bin/sh /Users/contax/src/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -I/usr/local/apache2/include  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -I/usr/local/apache2/include   -I/usr/local/apache2/include  -Isapi/apache2handler/ -I/Users/contax/src/php-5.1.4/sapi/apache2handler/ -DPHP_ATOM_INC -I/Users/contax/src/php-5.1.4/include -I/Users/contax/src/php-5.1.4/main -I/Users/contax/src/php-5.1.4 -I/usr/include/libxml2 -I/Users/contax/src/php-5.1.4/ext/date/lib -I/Users/contax/src/php-5.1.4/TSRM -I/Users/contax/src/php-5.1.4/Zend  -no-cpp-precomp  -I/usr/include -g -O2  -c /Users/contax/src/php-5.1.4/sapi/apache2handler/php_functions.c -o sapi/apache2handler/php_functions.lo 
/bin/sh /Users/contax/src/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -Imain/ -I/Users/contax/src/php-5.1.4/main/ -DPHP_ATOM_INC -I/Users/contax/src/php-5.1.4/include -I/Users/contax/src/php-5.1.4/main -I/Users/contax/src/php-5.1.4 -I/usr/include/libxml2 -I/Users/contax/src/php-5.1.4/ext/date/lib -I/Users/contax/src/php-5.1.4/TSRM -I/Users/contax/src/php-5.1.4/Zend  -no-cpp-precomp  -I/usr/include -g -O2  -c main/internal_functions.c -o main/internal_functions.lo 
gcc -bundle -bundle_loader /usr/local/apache2/bin/httpd -L/usr/local/apache2/lib -L/usr/local/apache2/lib -laprutil-1 -lsqlite3 -lexpat -liconv -L/usr/local/apache2/lib -lapr-1 -lpthread -I/usr/include -g -O2   -export-symbols /Users/contax/src/php-5.1.4/sapi/apache2handler/php.sym ext/libxml/libxml.o ext/pcre/pcrelib/pcre_chartables.o ext/pcre/pcrelib/pcre_ucp_searchfuncs.o ext/pcre/pcrelib/pcre_compile.o ext/pcre/pcrelib/pcre_config.o ext/pcre/pcrelib/pcre_dfa_exec.o ext/pcre/pcrelib/pcre_exec.o ext/pcre/pcrelib/pcre_fullinfo.o ext/pcre/pcrelib/pcre_get.o ext/pcre/pcrelib/pcre_globals.o ext/pcre/pcrelib/pcre_info.o ext/pcre/pcrelib/pcre_maketables.o ext/pcre/pcrelib/pcre_ord2utf8.o ext/pcre/pcrelib/pcre_refcount.o ext/pcre/pcrelib/pcre_study.o ext/pcre/pcrelib/pcre_tables.o ext/pcre/pcrelib/pcre_try_flipped.o ext/pcre/pcrelib/pcre_valid_utf8.o ext/pcre/pcrelib/pcre_version.o ext/pcre/pcrelib/pcre_xclass.o ext/pcre/php_pcre.o ext/ctype/ctype.o ext/date/php_date.o ext/date/lib/astro.o ext/date/lib/dow.o ext/date/lib/parse_date.o ext/date/lib/parse_tz.o ext/date/lib/timelib.o ext/date/lib/tm2unixtime.o ext/date/lib/unixtime2tm.o ext/dom/php_dom.o ext/dom/attr.o ext/dom/document.o ext/dom/domerrorhandler.o ext/dom/domstringlist.o ext/dom/domexception.o ext/dom/namelist.o ext/dom/processinginstruction.o ext/dom/cdatasection.o ext/dom/documentfragment.o ext/dom/domimplementation.o ext/dom/element.o ext/dom/node.o ext/dom/string_extend.o ext/dom/characterdata.o ext/dom/documenttype.o ext/dom/domimplementationlist.o ext/dom/entity.o ext/dom/nodelist.o ext/dom/text.o ext/dom/comment.o ext/dom/domconfiguration.o ext/dom/domimplementationsource.o ext/dom/entityreference.o ext/dom/notation.o ext/dom/xpath.o ext/dom/dom_iterators.o ext/dom/typeinfo.o ext/dom/domerror.o ext/dom/domlocator.o ext/dom/namednodemap.o ext/dom/userdatahandler.o ext/hash/hash.o ext/hash/hash_md.o ext/hash/hash_sha.o ext/hash/hash_ripemd.o ext/hash/hash_haval.o ext/hash/hash_tiger.o ext/hash/hash_gost.o ext/hash/hash_snefru.o ext/hash/hash_whirlpool.o ext/hash/hash_adler32.o ext/hash/hash_crc32.o ext/iconv/iconv.o ext/pdo/pdo.o ext/pdo/pdo_dbh.o ext/pdo/pdo_stmt.o ext/pdo/pdo_sql_parser.o ext/pdo/pdo_sqlstate.o ext/posix/posix.o ext/reflection/php_reflection.o ext/session/session.o ext/session/mod_files.o ext/session/mod_mm.o ext/session/mod_user.o ext/simplexml/simplexml.o ext/spl/php_spl.o ext/spl/spl_functions.o ext/spl/spl_engine.o ext/spl/spl_iterators.o ext/spl/spl_array.o ext/spl/spl_directory.o ext/spl/spl_sxe.o ext/spl/spl_exceptions.o ext/spl/spl_observer.o ext/sqlite/sqlite.o ext/sqlite/sess_sqlite.o ext/sqlite/pdo_sqlite2.o ext/sqlite/libsqlite/src/opcodes.o ext/sqlite/libsqlite/src/parse.o ext/sqlite/libsqlite/src/encode.o ext/sqlite/libsqlite/src/auth.o ext/sqlite/libsqlite/src/btree.o ext/sqlite/libsqlite/src/build.o ext/sqlite/libsqlite/src/delete.o ext/sqlite/libsqlite/src/expr.o ext/sqlite/libsqlite/src/func.o ext/sqlite/libsqlite/src/hash.o ext/sqlite/libsqlite/src/insert.o ext/sqlite/libsqlite/src/main.o ext/sqlite/libsqlite/src/os.o ext/sqlite/libsqlite/src/pager.o ext/sqlite/libsqlite/src/printf.o ext/sqlite/libsqlite/src/random.o ext/sqlite/libsqlite/src/select.o ext/sqlite/libsqlite/src/table.o ext/sqlite/libsqlite/src/tokenize.o ext/sqlite/libsqlite/src/update.o ext/sqlite/libsqlite/src/util.o ext/sqlite/libsqlite/src/vdbe.o ext/sqlite/libsqlite/src/attach.o ext/sqlite/libsqlite/src/btree_rb.o ext/sqlite/libsqlite/src/pragma.o ext/sqlite/libsqlite/src/vacuum.o ext/sqlite/libsqlite/src/copy.o ext/sqlite/libsqlite/src/vdbeaux.o ext/sqlite/libsqlite/src/date.o ext/sqlite/libsqlite/src/where.o ext/sqlite/libsqlite/src/trigger.o regex/regcomp.o regex/regexec.o regex/regerror.o regex/regfree.o ext/standard/array.o ext/standard/base64.o ext/standard/basic_functions.o ext/standard/browscap.o ext/standard/crc32.o ext/standard/crypt.o ext/standard/cyr_convert.o ext/standard/datetime.o ext/standard/dir.o ext/standard/dl.o ext/standard/dns.o ext/standard/exec.o ext/standard/file.o ext/standard/filestat.o ext/standard/flock_compat.o ext/standard/formatted_print.o ext/standard/fsock.o ext/standard/head.o ext/standard/html.o ext/standard/image.o ext/standard/info.o ext/standard/iptc.o ext/standard/lcg.o ext/standard/link.o ext/standard/mail.o ext/standard/math.o ext/standard/md5.o ext/standard/metaphone.o ext/standard/microtime.o ext/standard/pack.o ext/standard/pageinfo.o ext/standard/quot_print.o ext/standard/rand.o ext/standard/reg.o ext/standard/soundex.o ext/standard/string.o ext/standard/scanf.o ext/standard/syslog.o ext/standard/type.o ext/standard/uniqid.o ext/standard/url.o ext/standard/url_scanner.o ext/standard/var.o ext/standard/versioning.o ext/standard/assert.o ext/standard/strnatcmp.o ext/standard/levenshtein.o ext/standard/incomplete_class.o ext/standard/url_scanner_ex.o ext/standard/ftp_fopen_wrapper.o ext/standard/http_fopen_wrapper.o ext/standard/php_fopen_wrapper.o ext/standard/credits.o ext/standard/css.o ext/standard/var_unserializer.o ext/standard/ftok.o ext/standard/sha1.o ext/standard/user_filters.o ext/standard/uuencode.o ext/standard/filters.o ext/standard/proc_open.o ext/standard/streamsfuncs.o ext/standard/http.o ext/tokenizer/tokenizer.o ext/xml/xml.o ext/xml/compat.o ext/xmlreader/php_xmlreader.o ext/xmlwriter/php_xmlwriter.o TSRM/TSRM.o TSRM/tsrm_strtok_r.o TSRM/tsrm_virtual_cwd.o main/main.o main/snprintf.o main/spprintf.o main/php_sprintf.o main/safe_mode.o main/fopen_wrappers.o main/alloca.o main/php_scandir.o main/php_ini.o main/SAPI.o main/rfc1867.o main/php_content_types.o main/strlcpy.o main/strlcat.o main/mergesort.o main/reentrancy.o main/php_variables.o main/php_ticks.o main/network.o main/php_open_temporary_file.o main/php_logos.o main/output.o main/streams/streams.o main/streams/cast.o main/streams/memory.o main/streams/filter.o main/streams/plain_wrapper.o main/streams/userspace.o main/streams/transports.o main/streams/xp_socket.o main/streams/mmap.o Zend/zend_language_parser.o Zend/zend_language_scanner.o Zend/zend_ini_parser.o Zend/zend_ini_scanner.o Zend/zend_alloc.o Zend/zend_compile.o Zend/zend_constants.o Zend/zend_dynamic_array.o Zend/zend_execute_API.o Zend/zend_highlight.o Zend/zend_llist.o Zend/zend_opcode.o Zend/zend_operators.o Zend/zend_ptr_stack.o Zend/zend_stack.o Zend/zend_variables.o Zend/zend.o Zend/zend_API.o Zend/zend_extensions.o Zend/zend_hash.o Zend/zend_list.o Zend/zend_indent.o Zend/zend_builtin_functions.o Zend/zend_sprintf.o Zend/zend_ini.o Zend/zend_qsort.o Zend/zend_multibyte.o Zend/zend_ts_hash.o Zend/zend_stream.o Zend/zend_iterators.o Zend/zend_interfaces.o Zend/zend_exceptions.o Zend/zend_strtod.o Zend/zend_objects.o Zend/zend_object_handlers.o Zend/zend_objects_API.o Zend/zend_mm.o Zend/zend_default_classes.o Zend/zend_execute.o sapi/apache2handler/mod_php5.o sapi/apache2handler/sapi_apache2.o sapi/apache2handler/apache_config.o sapi/apache2handler/php_functions.o main/internal_functions.o  -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm  -o libs/libphp5.bundle && cp libs/libphp5.bundle libs/libphp5.so
/usr/bin/ld: unknown flag: -export-symbols
collect2: ld returned 1 exit status
make: *** [libs/libphp5.bundle] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-15 15:39 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-08-15 16:21 UTC] contax at phrenetic dot org
No dice. Still being returned:

/usr/bin/ld: unknown flag: -export-symbols
collect2: ld returned 1 exit status
make: *** [libs/libphp5.bundle] Error 1
 [2006-08-15 17:32 UTC] philip@php.net
I can confirm this problem on my machine too.
 [2006-08-15 20:14 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

--enable-versioning is not supported on OS X because of its linker limitations.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC