php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38259 SHM can not be removed.
Submitted: 2006-07-30 06:48 UTC Modified: 2006-07-30 10:16 UTC
From: aeolianmeson at blitzeclipse dot com Assigned:
Status: Not a bug Package: Semaphore related
PHP Version: 5.1.4 OS: Fedora 4
Private report: No CVE-ID: None
 [2006-07-30 06:48 UTC] aeolianmeson at blitzeclipse dot com
Description:
------------
The SHM id returned by shm_attach will produce an error when used with shm_remove ("PHP Warning:  shm_remove(): The parameter is not a valid shm_identifier in /clustershare/cluster/shm.php on line 15
"). It CAN be used to detach, though.

Reproduce code:
---------------
// The key used was returned from a call to ftok(), but was placed here staticly for testing.

$id = shm_attach(1360651186, 20000);
shm_detach($id);
shm_remove($id);


Expected result:
----------------
No error message.

Actual result:
--------------
Produces only the specified error message.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-30 10:16 UTC] tony2001@php.net
Because you cannot remove SHM segment if it's detached.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 29 01:03:36 2021 UTC