php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38231 mysqli_stmt_bind_param incorrect values
Submitted: 2006-07-27 08:21 UTC Modified: 2006-09-25 20:54 UTC
From: anton at ht-systems dot ru Assigned: georg (profile)
Status: Not a bug Package: MySQLi related
PHP Version: 5.1.4 OS: Linux
Private report: No CVE-ID: None
 [2006-07-27 08:21 UTC] anton at ht-systems dot ru
Description:
------------
web server placed on 32bit linux server with php 5.1.4 and mysql 4.1.18 client.

If i using database on 32bit linux server all work correctly, but if using 64bit lunix server after execute statement in database placed incorrect values.

in database i see:
instead of 19 I see 196864
instead of "RRRRRRRRR" I see "RRRRRRRRRюЂdef??юЂюb7_optЂ?a   ?*??a   ?*ђ?a   ?*??a "

Reproduce code:
---------------
$mys = new mysqli($mysql_['host'], $mysql_['username'], $mysql_['password'],
$mysql_['database']); 
$qu_insert = "INSERT INTO assort (ind, articul) VALUES (?, ?)"; 
$stmt = $mys->prepare($qu_insert); 
$ind = 19; 
$articul = "RRRRRRRRR"; 

$stmt->bind_param("is", $ind, $articul); 
$stmt->execute(); 
$stmt->close();


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-27 08:41 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

Not reproducible here.
Both MySQL server & client are 4.1.18.
 [2006-07-27 09:23 UTC] anton at ht-systems dot ru
I upgrade mysql server & client to 4.1.20 the same problem.

Also it would not be desirable to pass on 5.2 yet, it is stable?
 [2006-07-27 10:27 UTC] tony2001@php.net
You don't need to install it, you just need to build and test it, that doesn't required any actions regarding the existing PHP installation.
 [2006-07-27 10:35 UTC] anton at ht-systems dot ru
Has checked up with php5.2-200607270830, the problem has remained.
 [2006-07-27 10:42 UTC] tony2001@php.net
The database itself is on the same 64bit server or it's a remote DB?

 [2006-07-27 11:02 UTC] anton at ht-systems dot ru
Database on remote server on 64bit platform.

If to use the remote database on 32 bit platform that all works normally.
 [2006-07-27 22:24 UTC] judas dot iscariote at gmail dot com
works perfectly fine here PHP 5_2 64 bit linux using mysql client version 5.0.22.
 [2006-08-29 21:28 UTC] tony2001@php.net
Please try newer MySQL version and if the problem persists - please report it to bugs.mysql.com, since it looks like MySQL client library issue.
 [2006-09-18 14:49 UTC] anton at ht-systems dot ru
Problem not solved, Georg Richter  nor response for me.
 [2006-09-25 15:02 UTC] anton at ht-systems dot ru
Problem not solved, Georg Richter  nor response for me.
 [2006-09-25 20:54 UTC] tony2001@php.net
It's still not PHP problem.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 29 02:05:45 2022 UTC