php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38131 Upgrading from 5.1.2 to 5.1.4 crashes IIS periodically
Submitted: 2006-07-18 10:37 UTC Modified: 2010-12-20 12:16 UTC
From: michael at onlinecity dot dk Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.1.4 OS: Windows Server 2003 x64 SP1
Private report: No CVE-ID: None
 [2006-07-18 10:37 UTC] michael at onlinecity dot dk
Description:
------------
This occurs in Event Viewer in the Application log:
Faulting application php.exe, version 5.1.4.4, faulting module 
unknown, version 0.0.0.0, fault address 0x027f1c90.

Followed by each Application Pool using php crashing

I am using Zend Optimizer 3.0 and IIS is running in 32 bit compatibility mode.

These are my loaded extensions:
extension=php_mbstring.dll
extension=php_bz2.dll
extension=php_curl.dll
extension=php_exif.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_imap.dll
extension=php_ldap.dll
extension=php_mcrypt.dll
extension=php_mhash.dll
extension=php_mssql.dll
extension=php_mysql.dll
extension=php_openssl.dll
extension=php_pgsql.dll
extension=php_sockets.dll
extension=php_tidy.dll
extension=php_xmlrpc.dll
extension=php_xsl.dll
extension=php_fileinfo.dll
extension=php_zip.dll
extension=php_mysqli.dll
extension=php_pdo.dll
extension=php_soap.dll
extension=php_gzip.dll



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-18 10:50 UTC] tony2001@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.


 [2006-07-20 08:39 UTC] michael at onlinecity dot dk
I have reproduced the crash and catched it with IISState.
The report can be found here
http://www.onlinecity.dk/phpdump/IISState-1068.txt
and the dump file here http://www.onlinecity.dk/phpdump/1068-1153384102.zip

Both generated with windows debugging tools from june 16th.
 [2006-07-20 08:42 UTC] michael at onlinecity dot dk
I should mention that i generated this crash using the 5.2.x snapshot "Built On: Jul 20, 2006 06:30 GMT" with the debug package
 [2006-07-20 08:54 UTC] tony2001@php.net
Thank you, but that doesn't add any value.
We need a clear (GDB) backtrace, not some encrypted data.
And there are several open bug reports about it already, please add your comments to them, if you have anything to add.
 [2006-07-27 10:23 UTC] michael at onlinecity dot dk
The problem seems to be related to your building environment. I successfully built 5.1.4 today, both release and debug, and neither version crashed during IIS process recycle. This was built using Windows Platform SDK and Visual Studio 2005.
I suggest you try updating your platform sdk.
 [2006-07-27 10:33 UTC] tony2001@php.net
Unfortunately *I* don't have any Win32 build environment, so I can't upgrade it.
Also, I don't think that advices like "upgrade MSVC" or "install a service pack" help in any way - they are too generic to be used.
 [2010-12-20 12:16 UTC] jani@php.net
-Package: Tidy +Package: IIS related
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 15:04:09 2023 UTC