php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3809 DBM extension for Win32 PHP3 is malfunctioning and/or has a flaw
Submitted: 2000-03-11 10:10 UTC Modified: 2002-10-01 15:59 UTC
From: AdiF at Home dot com Assigned:
Status: Wont fix Package: DBM/DBA related
PHP Version: 3.0.15 OS: Windows 98SE/2000
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-03-11 10:10 UTC] AdiF at Home dot com
The DBM extension MUST have a flaw in it! I know about 5 or more people that have had the same problem as I did. I get the error:

Warning: not a valid database identifier 0

In my DBM script. I used the same script on a LINUX server and it worked! For everyone who tries to run their DBM script in Windows, it shows up. This bug has been with the Win32 version for a LONG time and it's time for it to be fixed. It's not something I'M doing wrong because I copied the EXACT script to a LINUX server and it worked, even with the database! It happens to ANY DBM script. I tried configuring PHP3 on OMNIHTTPd in Win98SE and IIS5.0 in Win2000! The same error appears ALL the time! Please examine that extension.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-10 15:16 UTC] jimw@php.net
duplicate of 2890.
 [2002-10-01 15:59 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 14:01:23 2020 UTC