php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38078 php_pdo_oci.dll and php_pdo_oci8.dll not working.
Submitted: 2006-07-12 13:26 UTC Modified: 2010-12-20 12:14 UTC
From: RQuadling at GMail dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 5CVS-2006-07-12 (snap) OS: Windows XP SP2
Private report: No CVE-ID:
 [2006-07-12 13:26 UTC] RQuadling at GMail dot com
Description:
------------
Trying to test PDO for OCI.

php-cli.ini has ...

extension=php_pdo.dll
extension=php_pdo_odbc.dll
extension=php_pdo_oci.dll
extension=php_pdo_oci8.dll

C:\PHP5\ext has ...

<12/07/2006 14:25:43 C:\>dir \php5\ext\php_pdo*.*
 Volume in drive C has no label.
 Volume Serial Number is 441B-EABB

 Directory of C:\php5\ext

12/07/2006  12:33            86,073 BANDVULC\RichardQ      php_pdo.dll
12/07/2006  12:33            32,834 BANDVULC\RichardQ      php_pdo_firebird.dll
12/07/2006  12:33            28,735 BANDVULC\RichardQ      php_pdo_mysql.dll
12/07/2006  12:33            32,829 BANDVULC\RichardQ      php_pdo_oci.dll
12/07/2006  12:33            32,830 BANDVULC\RichardQ      php_pdo_oci8.dll
12/07/2006  12:33            28,734 BANDVULC\RichardQ      php_pdo_odbc.dll
12/07/2006  12:33            81,983 BANDVULC\RichardQ      php_pdo_pgsql.dll
12/07/2006  12:33           254,016 BANDVULC\RichardQ      php_pdo_sqlite.dll
               8 File(s)        578,034 bytes
               0 Dir(s)   1,079,095,296 bytes free

Rights to ext directory ...

c:\php5\ext BUILTIN\Administrators:(OI)(CI)F
            BANDVULC\RichardQ:F
            CREATOR OWNER:(OI)(CI)(IO)F
            NT AUTHORITY\SYSTEM:(OI)(CI)F

php -m results in 2 windows dialogs and no OCI drivers for PDO.

Reproduce code:
---------------
php -m

Expected result:
----------------
[PHP Modules]
bcmath
calendar
com_dotnet
ctype
curl
date
dom
ftp
gd
hash
iconv
libxml
mhash
mssql
odbc
pcre
PDO
PDO_OCI
PDO_OCI8
PDO_ODBC
Reflection
session
SimpleXML
SPL
standard
tidy
tokenizer
wddx
xml
xmlreader
xmlrpc
xmlwriter
xsl
zlib

Actual result:
--------------
Warning: PHP Startup: Unable to load dynamic library 'C:\PHP5\ext\php_pdo_oci.dll' - The specified module could not be found.
 in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library 'C:\PHP5\ext\php_pdo_oci8.dll' - The specified module could not be found.
 in Unknown on line 0
[PHP Modules]
bcmath
calendar
com_dotnet
ctype
curl
date
dom
ftp
gd
hash
iconv
libxml
mhash
mssql
odbc
pcre
PDO
PDO_ODBC
Reflection
session
SimpleXML
SPL
standard
tidy
tokenizer
wddx
xml
xmlreader
xmlrpc
xmlwriter
xsl
zlib

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-12 13:35 UTC] tony2001@php.net
You need to install Oracle Instant Client libraries to be able to use these extensions.
 [2006-07-12 13:52 UTC] RQuadling at GMail dot com
Doh!

OCI.DLL not found.

Shoot me now!

Though, some mention of this on the PDO_OCI pages would be useful. A Documentation problem perhaps?
 [2010-10-04 18:13 UTC] tyrussays at yahoo dot com
Stating the obvious maybe but make sure Oracle (XE 10g or at least the client) are installed on the server and  don't forget to restart. i just wasted a half hour because I didn't restart the server. As soon as I did it was able to load it all.
 [2010-12-20 12:14 UTC] jani@php.net
-Package: Tidy +Package: OCI8 related
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 18:02:13 2014 UTC