php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38074 mysql_affected_rows bug!
Submitted: 2006-07-12 07:56 UTC Modified: 2006-07-12 08:59 UTC
From: nimce4u at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.1.4 OS: Windows XP Pro
Private report: No CVE-ID: None
 [2006-07-12 07:56 UTC] nimce4u at gmail dot com
Description:
------------
I'm using the mysql function called:
mysql_affected_rows();
now it has to give the number of the affected rows on UPDATE,INSERT,DELETE queries only!
But it gives me the number of rows ever if I use SELECT query!
thank you


Reproduce code:
---------------
<?php
mysql_connect("localhost","nimce");
mysql_select_db("magazine");
mysql_query("SELECT * from users");
print mysql_affected_rows();
?>
there are 4 users!

Expected result:
----------------
-1,because I used SELECT query

Actual result:
--------------
4


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-12 08:59 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 12:03:36 2021 UTC