php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38072 autocommit(FALSE) is not working.
Submitted: 2006-07-11 21:30 UTC Modified: 2006-07-12 09:51 UTC
From: canipe_chris at yahoo dot com Assigned:
Status: Closed Package: MySQLi related
PHP Version: 5.1.4 OS: SunOS 5.8
Private report: No CVE-ID:
 [2006-07-11 21:30 UTC] canipe_chris at yahoo dot com
Description:
------------
Using autocommit(FALSE) on a mysqli object does not turn autocommit off. There is more information at the URL listed under "Reproduce code."

Reproduce code:
---------------
http://www.phpfreaks.com/forums/index.php/topic,99562.msg392129.html#msg392129

Expected result:
----------------
I expect the result to be "Autocommit is 1 Autocommit is 0".

Actual result:
--------------
The actual result is "Autocommit is 1 Autocommit is 1".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-11 23:12 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

Works just fine here.
 [2006-07-12 02:17 UTC] canipe_chris at yahoo dot com
Tony,

I do not have a Sun machine at home, and I am unable to make this request at my place of work at the moment. For now, I'll use the work-around of mysqli->query('set autocommit = 0').

I was fairly certain this wasn't a bug since it worked in Windows; however, my search for why this was happening turned up empty handed. Is there anything in the php.ini, my.cnf, or configure that might affect autocommit, or does mysqli work "out of the box"?

Thanks for your time.
 [2006-07-12 09:51 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 21:01:55 2014 UTC