php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38026 IE 6 and zlib.output_compression sometimes does not work
Submitted: 2006-07-06 22:26 UTC Modified: 2006-07-07 08:18 UTC
From: php at seven dot net dot nz Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 5.1.4 OS: Windows XP
Private report: No CVE-ID:
 [2006-07-06 22:26 UTC] php at seven dot net dot nz
Description:
------------
Apache 2.0.56 or 2.2.2.
Windows XP Pro.
PHP 5.1.4.

When browsing around a site in IE 6, occasionally a page will show up as blank. Oddly enough, the IE address bar will not even update to show the URL you are requesting.

1. The headers appear to be sent correctly.
2. Nothing untoward is reported in the error log (process crashes or segfaults).
3. Only affects IE 6 (and possibly earlier). No problems with IE 7 or Firefox.
4. Only happens when zlib.output_compression is on.
5. Only happens some of the time, but with all of the pages - between 20 and 60% of the time, depending on the machine I tested on.
6. Refreshing will always show the page correctly.
7. This has been verified by 10 distinct IE 6 clients.

I realise this may not be enough information; let me know what you need and I'll try and get more data.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-06 22:27 UTC] tony2001@php.net
>3. Only affects IE 6 (and possibly earlier). No problems with IE 7 or Firefox.
Why do you report it here and not to MS support then?
 [2006-07-06 22:32 UTC] php at seven dot net dot nz
Microsoft are unlikely to care, whereas I would hope the PHP team would be interested if a feature does not work in a browser used by 90% of the internet population.
 [2006-07-07 08:18 UTC] tony2001@php.net
Well, PPH group is unlikely able to fix MSIE.
Not PHP problem -> bogus.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 09:02:28 2014 UTC