php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37944 Very Slow session_start on nfs-mount
Submitted: 2006-06-28 10:04 UTC Modified: 2006-06-28 11:13 UTC
From: g42 at gmx dot net Assigned:
Status: Not a bug Package: Session related
PHP Version: 5.1.4 OS: Gentoo Linux 2006.0
Private report: No CVE-ID: None
 [2006-06-28 10:04 UTC] g42 at gmx dot net
Description:
------------
Some PHP-Sites take very long to load (>60 seconds). A famous example is phpmyadmin. The wait-time accours after login, oder after changing the database. CacheGrind (created with xdebug) shows that php::session_start takes 60.011ms to start (1 call) while changing to another Database. The total script took 60.112ms

php.ini changes:
session.save_path = "/www/phptemp/sessions"

/www is a nfs-mount, mounted with options:
soft,retry=5,nfsvers=3,posix,tcp

server-export:
/raid/www       192.168.1.0/24(rw,sync,root_squash)

Reproduce code:
---------------
see phpmyadmin-2.8.1 http://www.phpmyadmin.net

Expected result:
----------------
script-execution time <1 second

Actual result:
--------------
script-execution time >60 seconds

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-28 10:29 UTC] tony2001@php.net
Apparently it was bad idea to use NFS for script, as I/O operations are very slow with NFS.
Not PHP problem.
 [2006-06-28 11:13 UTC] g42 at gmx dot net
sorry, but a difference of 60 seconds just can't really be a problem of slow I/O. It's some kind of timeout i think, because all other sites on this share are fast as hell, except those who use sessions as well...

if i change session.save_path to "/tmp" (which is on a local reiserfs-partition) everything runs smooth and without these problems...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Oct 13 21:01:26 2019 UTC