php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #379 Building with apxs -> SIGSEGV after loading module php3
Submitted: 1998-05-16 12:45 UTC Modified: 1998-11-25 01:57 UTC
From: clkao at CirX dot ORG Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0 Release Candidate 4 OS: FreeBSD 2.2.6-Stable
Private report: No CVE-ID: None
 [1998-05-16 12:45 UTC] clkao at CirX dot ORG
I configured php3rc4 (with apache 1.3b6) with:
./configure --with-system-regex --with-apxs --with-mysql \
            --with-config-file-path=/usr/local/etc

first of all I found that the config.h should have turned on
HAVE_AP_COMPAT_H (since apxs is 1.3+ only), and then I found
the configure script should add an option defining perl path,
since the system-installed perl on FreeBSD is perl4, and 
package-installed perl(5) is in /usr/local/bin.

I've copy php3.ini to /usr/local/etc, everything seemed fine
except : after apache load the php3 module, soon it got a 
segmentation fault. and if I didn't indicate apache to load
php3 module at startup time, but add the line in config file
then restart apache, it'll coredump only when doing php3 
related work.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-11-25 01:57 UTC] rasmus
Tested with latest Apache and PHP - unable to reproduce this problem
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 18:03:35 2021 UTC