php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37869 php doesn't allows to access remote linked servers!
Submitted: 2006-06-21 07:14 UTC Modified: 2006-06-21 07:41 UTC
From: mgiurgiu at eurotopo dot ro Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.4.2 OS: Windows XP
Private report: No CVE-ID: None
 [2006-06-21 07:14 UTC] mgiurgiu at eurotopo dot ro
Description:
------------
I have created a Linked server(MSSQL 2000 server) at an Interbase database and works perfectly from Querry Analyzer
The problem occurs when I try to execute the query from php (by using  query); I've got an error : "DB Error: unknown error".
It seems that php doesn't allows to access remote linked servers!


Reproduce code:
---------------
$db =& DBWrapper::get();

.......
$sql =
	"select U.*
	 from   OPENQUERY(FB, 'select * from users') U
	 where  U.USER_ACCOUNT = " . "MGI";
	$result =& $db->query($sql);
if (PEAR::isError($result)) {
		die($result->getMessage());
	}

Expected result:
----------------
no error

Actual result:
--------------
"DB Error: unknown error".


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-21 07:41 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 15:01:29 2024 UTC