php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37843 I start getting COM Surrogate crushes after installing php as ISAPI
Submitted: 2006-06-19 07:24 UTC Modified: 2006-07-20 15:29 UTC
Votes:5
Avg. Score:4.2 ± 1.2
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:5 (100.0%)
From: dragos dot matachescu at enterprise-concept dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.1.4 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2006-06-19 07:24 UTC] dragos dot matachescu at enterprise-concept dot com
Description:
------------
I installed php as ISAPI on IIS using php.ini-recommended, when I start/stop IIS I get from time to time "COM Surrogate error, Data Execution Prevention ...", in the event viewer I see these log entries:

Faulting application dllhost.exe, version 5.1.2600.2180, faulting module unknown, version 0.0.0.0, fault address 0x01275c80.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Reproduce code:
---------------
There is no code. Error seems to appear random, I could not find a behaviour pattern that reproduces the error. I assume a memory leak somewhere.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-19 07:28 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2006-06-19 08:46 UTC] dragos dot matachescu at enterprise-concept dot com
I think I know why it happens. I tested, and it seems it is because:

- I have c:\php put in the path env variable (it does not matter if it is the first in the path or last)

- I have mssql 2000 sp4 installed on my computer

- mssql has the following dll ntwdblib.dll in c:\windows\system32, the file version is 2000.80.2039.0

- in C:\php there is also ntwdblib.dll as part of php distribution, but the file version is 2000.2.8.0

  If I rename/delete the dll in the php distribution the problem seems to go away. I will monitor this further, and let you know if this is not it.

  Thank you,
  Dragos
 [2006-06-19 09:39 UTC] dragos dot matachescu at enterprise-concept dot com
... is not the dll thing I thought it was :(. It keeps crushing. I tried the debugger + symbols as you suggested in your email, the problem is MSVC6 does not start when I hit Cancel for debugging (although I have it installed obviously). As I said, I am running ISAPI version and is dllhost.exe the process that crushes. I intercepted the error report that is sent to Microsoft, I can send you the crush dump dllhost.exe.mdmp and appcompat.txt if it helps you...
 [2006-06-23 10:36 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-06-24 06:44 UTC] dragos dot matachescu at enterprise-concept dot com
I updated as instructed with http://snaps.php.net/win32/php5.2-win32-latest.zip, Ill keep it under observation.
 [2006-06-24 07:45 UTC] dragos dot matachescu at enterprise-concept dot com
It does not work. With 5.2 I get the same error in the same conditions (when restarting IIS Web Service, or when restarting the computer - which obviously stops the www service), I get the dllhost crash, and after the computer is restarted, I also get the com surogate error, with the error report to be sent to Microsoft (it is not until I restart the computer that the com surrogate error appears and is recorded in Event Viewer, must be some thing related to how windows records these type of events). However, if I get 5 dllhost crashes with starting-restarting the iis service, after computer restart I get 5 com surogate errors one after another.
 [2006-06-24 07:47 UTC] dragos dot matachescu at enterprise-concept dot com
As I said, I cannot trap this error in a debugger. I can send you dllhost.exe crash dump, but I think that probably it would be best to pass this to developers and see if they can reproduce the error ...
 [2006-07-20 15:29 UTC] mike@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 15 02:01:24 2019 UTC