php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #37837 Numeric keys for session variables are lost
Submitted: 2006-06-18 14:29 UTC Modified: 2007-08-17 20:38 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: php-bugs at T43 dot mine dot nu Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-06-18 14:29 UTC] php-bugs at T43 dot mine dot nu
Description:
------------
The documentation in the manual is correct but very hard to find due to its location in the "preface" to the "examples" on the Session pages. Also a few words in the sections on Predefined Variables would be helpful, because it is a bit different than, say, $_COOKIE. The absence of the information, where $_SESSION is explained, would signify its insignificance or nonexistence.

related pages http://www.php.net/manual/en/language.variables.predefined.php

http://www.php.net/manual/en/reserved.variables.php#reserved.variables.session

bug 27078

http://www.php.net/manual/en/ref.session.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-18 14:36 UTC] php-bugs at T43 dot mine dot nu
The hard-to-find documentation sentence I'm about is:

"The keys in the $_SESSION associative array are subject to the same limitations as regular variable names in PHP,"
 [2007-08-17 20:38 UTC] vrana@php.net
The information is available.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 05:01:26 2019 UTC