php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37701 fopen/file_get_contents fails on opening files over FTP
Submitted: 2006-06-05 13:41 UTC Modified: 2006-06-05 14:41 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ionut dot aivanesei at amdocs dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 5.1.4 OS: Solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ionut dot aivanesei at amdocs dot com
New email:
PHP Version: OS:

 

 [2006-06-05 13:41 UTC] ionut dot aivanesei at amdocs dot com
Description:
------------
I cannot use fopen/file_get_contents on Solaris over FTP (the same is working fine in HP-UX, AIX).


Reproduce code:
---------------
<?php

 echo file_get_contents('ftp://...@server/filename');

?>


Expected result:
----------------
contents of 'filename' should be printed

Actual result:
--------------
files is not opened and a warnign is shown:


Warning: file_get_contents(ftp://...@server/filename) [function.file-get-contents]: failed to open stream: FTP server reports 500 'SIZE /filename': command not understood. in script.php on line 3


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-05 13:53 UTC] tony2001@php.net
What kind of FTP server is that?
 [2006-06-05 14:12 UTC] ionut dot aivanesei at amdocs dot com
it is the default FTP server which comes with SunOS 5.x
 [2006-06-05 14:37 UTC] tony2001@php.net
Duplicate of bug #35765.
 [2006-06-05 14:41 UTC] ionut dot aivanesei at amdocs dot com
I know that, but do you have a solution or a workaround?
I really cannot continue with this error and I don't know how to avoid it.

Any help will be much appreciated.

Thanks,
Ionutz
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 08:05:45 2022 UTC