php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37588 COM Property propputref converts to PHP function and can't be accesed
Submitted: 2006-05-25 09:38 UTC Modified: 2006-12-24 10:05 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: dtyschenko at soft-ukraine dot com Assigned:
Status: Closed Package: COM related
PHP Version: 5.1.4 OS: Windows XP SP2
Private report: No CVE-ID:
 [2006-05-25 09:38 UTC] dtyschenko at soft-ukraine dot com
Description:
------------
When COM property is marked with propputref it looks like function in com_print_typeinfo and can't be accessed by:

$a->property = $b
or
$a->property($b)

I'm just get com_exception with message 'Error [0x80020003] Member not found.'

Reproduce code:
---------------
<?php
	$Engine = new COM("SAPI.SpVoice");
	$File = new COM("SAPI.SpFileStream");
	
	$File->Open("C:\\1.wav", 3, false);
	
	$Engine->AudioOutputStream = $File; // com_exception
	$Engine->Speak("Hello World!", 0);
	
	$File->Close();
	
	unset($File);
	unset($Engine);
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-24 10:05 UTC] rrichards@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 10:02:09 2014 UTC