php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #37515 convert month name to month number
Submitted: 2006-05-19 08:21 UTC Modified: 2017-03-11 21:28 UTC
Votes:15
Avg. Score:4.4 ± 0.8
Reproduced:13 of 13 (100.0%)
Same Version:6 (46.2%)
Same OS:8 (61.5%)
From: erelsgl at cs dot technion dot ac dot il Assigned: heiglandreas (profile)
Status: Closed Package: Calendar related
PHP Version: 4.4.2 OS: irrelevant
Private report: No CVE-ID: None
 [2006-05-19 08:21 UTC] erelsgl at cs dot technion dot ac dot il
Description:
------------
regarding the calendar extension:
http://php.net/manual/en/ref.calendar.php

I suggest adding functions to convert a month name in a given calendar to a month number, and to convert a date in a string to a date array, similar to "strtotime" but for  all available calendars.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-30 18:47 UTC] cmb@php.net
-Package: Feature/Change Request +Package: Calendar related
 [2017-03-11 21:28 UTC] heiglandreas@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: heiglandreas
 [2017-03-11 21:28 UTC] heiglandreas@php.net
This Issue is by now over 10 years old and targets an unsupported PHP-Version. And since the intl-package is part of any supported PHP-Version it supports IntlCalendar::get() that returns the number of any given calendar I'D say this is issue is already closed…
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 06:01:31 2024 UTC