|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #375 Repeated access to oracle database causes normal cgi scripts to hang
Submitted: 1998-05-14 12:08 UTC Modified: 1998-05-16 02:25 UTC
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: jase at sensis dot com Assigned: rasmus (profile)
Status: Closed Package: Oracle related
PHP Version: 3.0 Release Candidate 4 OS: Solaris 2.5.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: jase at sensis dot com
New email:
PHP Version: OS:


 [1998-05-14 12:08 UTC] jase at sensis dot com
We're using an Oracle 7.3.(2.2.0) database and Apache.
Configured PHP with --with-apache=<path to apache> --with-oracle=<path to oracle> --enable-track-vars --with-system-regex

How to reproduce the problem:
View a php page that talks to the oracle database, and refresh it many times ( > 10).  Then run a normal cgi script (you may need to refresh this several times).  Eventually, the script will not load.  The httpd process serving it will increase it's utilization, making the host very sluggish.  The process' utilization never comes down.

I've tried apache 1.3b6 and 1.2.6 with the same results.  I've also tried compiling apache with
(as per problem id 1), but it still did not help.

All cgi scripts are affected by this.  The one I use to test is test-cgi, which comes with Apache.

When I look at the Apache server status, the process which is out of controll has a status of W, which is "Sending Reply".  The cgi script itself does not show up in the list of processes using ps.



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-16 02:25 UTC] rasmus
This is most likely fixed, and it wasn't related to the Oracle support specifically.  Try the latest CVS.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 04:03:37 2021 UTC