php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37449 Compile warnings from 'ext/standard/datetime.c'
Submitted: 2006-05-15 18:31 UTC Modified: 2006-05-16 00:15 UTC
From: ed at cubelike dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.1.4 OS: Linux 2.4.20-021
Private report: No CVE-ID: None
 [2006-05-15 18:31 UTC] ed at cubelike dot com
Description:
------------
When compiling PGP I see the following two warnings:

/home/updateuser/sources/php-5.1.4/ext/standard/datetime.c: In function `zif_strptime':
/home/updateuser/sources/php-5.1.4/ext/standard/datetime.c:104: warning: assignment makes pointer from integer without a cast

Reproduce code:
---------------
At Shell, in php-5.1.4 dir:

./configure --prefix=/apps/php5 --with-bz2 --with-mysql=/apps/mysql --with-apxs2=/apps/httpd/bin/apxs --with-libxml-dir=/apps/libxml2 --with-zlib=/apps/zlib --with-config-file-path=/apps/php5/config

make



Expected result:
----------------
Compiles cleanly (without any errors or warnings).

Actual result:
--------------
Compiles OK, but generates the following warnings:

/home/updateuser/sources/php-5.1.4/ext/standard/datetime.c: In function `zif_strptime':
/home/updateuser/sources/php-5.1.4/ext/standard/datetime.c:104: warning: assignment makes pointer from integer without a cast

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-15 18:32 UTC] ed at cubelike dot com
When compiling PGP <-- should be PHP; sorry!
 [2006-05-15 22:24 UTC] tony2001@php.net
Actually I doubt anybody is going to fix it.
It's caused by the ugly mess in the GLIBC and I don't think this warning worth spending a day or two on figuring out which #defines are required to make GLIBC happy.
 [2006-05-15 22:25 UTC] tony2001@php.net
But we would welcome a patch, of course.
 [2006-05-15 22:30 UTC] ed at cubelike dot com
Mleh, I've not used gcc in .. ugh .. years. 

javac has been my compiler of choice -- yes Java, not C[++] so I really don't think I'm the person to be harking about looking for this.

Regardless, maybe someone else can look into it.
 [2006-05-16 00:15 UTC] iliaa@php.net
The issue is that the _XOPEN_SOURCE define that supposed to 
include the function declaration does not work, hence the 
warning message.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 08:01:23 2020 UTC