php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37433 dns_get_record() is not defined, if --disable-all is set
Submitted: 2006-05-14 02:30 UTC Modified: 2006-05-14 16:42 UTC
From: sy at go2panel dot com Assigned:
Status: Not a bug Package: Network related
PHP Version: 5.1.4 OS: RHEL 4.0
Private report: No CVE-ID: None
 [2006-05-14 02:30 UTC] sy at go2panel dot com
Description:
------------
PHP 5.1.4 is compiled with minimum options using --disable-all

Function dns_get_record() gives this error:
PHP Fatal error:  Call to undefined function dns_get_record() in


Here is CODE:
=================
echo phpversion() ."\n";
echo gethostbyname('damla.net') ."\n";
var_dump(dns_get_record('damla.net')) ."\n";
die();

Here is OUTPUT:
===============
5.1.4
216.71.156.144
PHP Fatal error:  Call to undefined function dns_get_record() in 




Reproduce code:
---------------
echo phpversion() ."\n";
echo gethostbyname('damla.net') ."\n";
var_dump(dns_get_record('damla.net')) ."\n";
die();

Expected result:
----------------
dns_get_record() should be defined

OR

Enable directive to enable it should be document, apparently disabled by --disable-all

I have tested the same thing using 5.1.2 WITHOUT --disable-all and it works.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-14 13:00 UTC] tony2001@php.net
This function doesn't depend on configure options and enabled when possible.

 [2006-05-14 15:54 UTC] sy at go2panel dot com
I do not see a logical explanation WHERE
php version = 5.1.4 AND
gethostbyname is working AND
dns_get_record is NOT
 [2006-05-14 16:01 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

They do not use the same system functions or libraries.

Please keep this bug as bogus and check the sources before doing any further comments.
 [2006-05-14 16:42 UTC] sy at go2panel dot com
This turns to be missing documentation on dns_get_record() function.

It is not available on some older systems.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 02:01:26 2019 UTC