|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37413 if flex is outdated, error does not occur in configure stage
Submitted: 2006-05-11 20:04 UTC Modified: 2006-05-11 22:05 UTC
From: Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.1.5CVS OS: gentoo linux (VMWare)
Private report: No CVE-ID:
 [2006-05-11 20:04 UTC]
I had flex 2.5.33 installed, and needed 2.5.4, but the first error message was a brief "flex needs to be 2.5.4" that scrolled by so fast in ./configure that I missed it.

The next error was fatal, and was when zend_language_scanner.c could not be found.

Basically, $LEX was being set to "exit 0;" which did prevent generation of a bad zend_language_scanner.c, but the error message was not helpful.

Better would be "flex is out of date" and termination while configuring

This is from a CVS checkout, which is obviously different from a snapshot or release build.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-11 22:05 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Wed Oct 07 08:01:41 2015 UTC