php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37362 Make halts on semicolon in function declaration
Submitted: 2006-05-08 08:15 UTC Modified: 2006-05-08 08:37 UTC
From: lobster2 at xs4all dot nl Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: * OS: AIX 5.2 ML07
Private report: No CVE-ID: None
 [2006-05-08 08:15 UTC] lobster2 at xs4all dot nl
Description:
------------
During make of PHP 5.1.3 and PHP 5.1.4 on AIX 5.2 ML07  
with xlc 6.0 the process halts on syntax errors. 
 

Reproduce code:
---------------
$ make
[...]
"Zend/zend_language_parser.c", line 2585.1: 1506-046 (S)   
Syntax error.   
[... and after fixing the previous error ...]   
"Zend/zend_ini_parser.c", line 1081.1: 1506-046 (S) Syntax   
error.

Stop.

Expected result:
----------------
Fix: comment out the line previous to the one reported, 
with the single semicolon on its own. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-08 08:17 UTC] lobster2 at xs4all dot nl
$ diff zend_language_parser.c.orig zend_language_parser.c 
2582c2582,2583 
<     ; 
--- 
> # Next line commented out on AIX 5.2 ML07 with xlc 6.0 
> #    ; 
 
 
$ diff zend_ini_parser.c.orig zend_ini_parser.c 
1078c1078,1079 
<     ; 
--- 
> # Next line commented out on AIX 5.2 ML07 with xlc 6.0 
> #    ;
 [2006-05-08 08:37 UTC] helly@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is a generated file. So the problem is either the generator, you need byacc not yacc. Or detection of your build environment.

For build environment requirements check this: http://www.php.net/anoncvs.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 09 04:01:23 2020 UTC