php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37327 Can't turn off magic_quotes_gpc
Submitted: 2006-05-05 11:13 UTC Modified: 2006-06-20 14:51 UTC
From: davojan at mail dot ru Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 5.1.4 OS: FreeBSD 6.0
Private report: No CVE-ID: None
 [2006-05-05 11:13 UTC] davojan at mail dot ru
Description:
------------
In my php.ini (/usr/local/etc/php.ini):
magic_quotes_gpc = Off
magic_quotes_runtime = Off

phpinfo() gives:
magic_quotes_gpc     On  On
magic_quotes_runtime Off Off

There are no additional settings in my .htaccess.

my configure:
'./configure' '--enable-versioning' '--enable-memory-limit' '--with-config-file-path=/usr/local/etc' '--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all' '--enable-session' '--with-pcre-regex' '--enable-xml' '--enable-libxml' '--with-libxml-dir=/usr/local' '--enable-dom' '--with-xsl' '--with-zlib' '--enable-sockets' '--with-gd' '--disable-gd-jis-conv' '--enable-gd-native-ttf' '--with-iconv=/usr/local' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr/local' '--with-freetype-dir=/usr/local' '--enable-reflection' '--with-mysql' '--with-pdo-mysql' '--with-pear' '--with-openssl' '--with-apxs=/usr/local/sbin/apxs' '--enable-fastcgi' '--enable-force-cgi-redirect' '--disable-ipv6' '--prefix=/usr/local' 'i386-portbld-freebsd6.0'

I had to downgrade back to 5.1.2, it works fine with the same configure.

Whas is happening guys? Are you going to release php-5.1.5 after to days? :))

May be it is related to bug #36257, but in 5.1.2 it's ok.

O, almost forgot, it's apache 1.3.34 + mod_php.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-05 11:39 UTC] tony2001@php.net
And which php.ini file is used according to phpinfo() ?
 [2006-05-05 12:05 UTC] davojan at mail dot ru
Ups!
"Configuration File (php.ini) Path" from phpinfo()
 for php 5.1.4: /usr/local/etc
 for php 5.1.2: /usr/local/etc/php.ini

The file is on it's place. I didn't touch it.
Anyway, it is a bug.
 [2006-05-05 12:34 UTC] tony2001@php.net
>for php 5.1.4: /usr/local/etc
Which means php.ini is not used at all.
Make sure it's readable to Apache.
 [2006-05-05 13:01 UTC] davojan at mail dot ru
Of course it's readable.
ls -l php.ini
46 -rw-r--r--  1 root  wheel  45644 Apr 13 05:48 php.ini

My operations:
1. cd /usr/ports/distfiles/php-5.1.4
   ./configure [my options]
   make install
   /usr/local/etc/rc.d/apache.sh restart

   result: php.ini is not used
2. cd ../php-5.1.2
   ./configure [the same options]
   make install
   /usr/local/etc/rc.d/apache.sh restart

   result: php.ini is used

I don't change anything in httpd.conf or php.ini, don't reinstall apache or anything else.
 [2006-05-05 18:50 UTC] mike@php.net
Try /usr/local/etc/ (note trailing slash) in configure.
 [2006-05-16 10:44 UTC] davojan at mail dot ru
I've tried with trailing slash - this didn't help.
In php-5.1.2 it's ok either with or without slash.
Note that I tried to install 5.1.4 on gentoo linux system - it's ok there, on FreeBSD 6 - not. :((
 [2006-05-16 13:46 UTC] iliaa@php.net
Do you have any other ini files inside the /usr/local/etc/ 
directory or perhaps if you are testing in CLI that there is 
no php.ini or php-cli.ini inside the directory you are running 
the test script from
 [2006-05-17 06:17 UTC] davojan at mail dot ru
In /usr/local/etc/:
php.ini
php.ini-dist
php.ini-recommended
pear.conf

I am testing mod_php, not CLI
 [2006-06-14 16:41 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-06-14 17:01 UTC] davojan at mail dot ru
I've just tried the latest snapshot (php5.2-200606141630) - it's ok, all works, thank you!
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 18:01:30 2024 UTC