php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37312 Interbase Library Causes Firebird instability under load
Submitted: 2006-05-04 16:43 UTC Modified: 2006-05-06 09:10 UTC
From: shizius at hotmail dot com Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.1.3 OS: Windows XP, 2K, 2003
Private report: No CVE-ID: None
 [2006-05-04 16:43 UTC] shizius at hotmail dot com
Description:
------------
Using the php_interbase.dll extension causes Firebird instability (Crashes, Deadlocks, and BUGCHECKs).

I tried Firebird 1.5.2, Firbeird 1.5.3 and Firebird 2.0 RC1
I tried PHP 5.1.2, PHP 5.0.5

It happens most often while PHP is running as an Apache2 module.  It happens less often, but still happens, when
PHP is running as a CGI under Apache2

I believe it is a thread-safety issue in the 
php_interbase.dll or in the gds32.dll that comes with PHP.

I tried using the GDS32.dll from Firebird, and it has similar
problems.

I know that this is a problem either with php_interbase.dll
or with gds32.dll because when I use ODBC to connect to
firebird everything works great.


Reproduce code:
---------------
The database has to be under heavy load to reproduce this.

I have 50-200 simultaneous connections to the database with
a combination of read-only and write transactions and a lot
data going back and forth.

Expected result:
----------------
I expect the native access method to firebird to be stable.

Actual result:
--------------
I get BUGCHEKs, CRASHES, and unexplained DEADLOCKS.

FB2.0 RC1:
PDD-STANK (Server)	Wed May 03 21:04:29 2006
	Database: C:\DB.FDB
	internal gds software consistency check (invalid SEND request (167), file: exe.cpp line: 494)

FB 1.5.3:
PDD-STANK (Server)	Tue Apr 18 16:46:58 2006
	Database: C:\DB.FDB
	internal gds software consistency check (invalid SEND request (167))

PDD-STANK (Client)	Tue Apr 18 18:13:03 2006
	C:\Firebird\bin\fbserver.exe: terminated abnormally (4294967295)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-04 17:05 UTC] tony2001@php.net
So the database server crashes, not web server, right?
 [2006-05-05 20:27 UTC] shizius at hotmail dot com
yes.
 [2006-05-06 09:10 UTC] tony2001@php.net
So report it to Firebird developers.
Not PHP problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 14:01:24 2020 UTC