php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37307 !!PHP Warning: PSPELL couldn't open the dictionary. reason: No word lists can b
Submitted: 2006-05-04 12:59 UTC Modified: 2006-05-04 13:02 UTC
From: ushastry at techbooks dot com Assigned:
Status: Not a bug Package: Pspell related
PHP Version: 4.4.2 OS: Windows 2k Professional
Private report: No CVE-ID: None
 [2006-05-04 12:59 UTC] ushastry at techbooks dot com
Description:
------------
Hi!,

Platform Details

PHP: PHP-4.4.2 (Downloaded zip file from us2.php.net)
OS:Win2k
WebServer: IIS5

Also installed these..downloaded from aspell.net/win32(C:/Aspell)

Aspell-0-50-3-3-Setup.exe
Aspell-en-0.50-2-3.exe

my phpinfo() shows 

          pspell
PSpell Support  enabled  

When I try to run PHP script contaning below code(partial)

$path_to_personal_dictionary = dirname(__FILE__) . "/personal_dictionary/MPWordS.txt";

//If pspell doesn't exist, then include the pspell wrapper for aspell.
if(!function_exists('pspell_suggest'))
{
	// Set the path to aspell if you need to use it.
	define('ASPELL_BIN','/usr/bin/aspell');
	require_once ("pspell_comp.php");
}

// Create and configure a link to the pspell module.

$pspell_config = pspell_config_create("en");
pspell_config_mode($pspell_config, PSPELL_FAST);

if($usePersonalDict)
{
	// Allows the use of a custom dictionary (Thanks to Dylan Thurston for this addition).
	pspell_config_personal($pspell_config, $path_to_personal_dictionary);
}

$pspell_link = pspell_new_config($pspell_config); //Here comes the error...

Getting below error..

!!PHP Warning: PSPELL couldn't open the dictionary. reason: No word lists can be found for the language "en". in c:\inetpub\wwwroot\spell_checker\spell_checker.php on line 76 


Pls suggest the possible fix here..


Thanks,
Umesh Shastry



Reproduce code:
---------------
!!PHP Warning: PSPELL couldn't open the dictionary. reason: No word lists can be found for the language "en". in c:\inetpub\wwwroot\spell_checker\spell_checker.php on line 76 


Expected result:
----------------
!!PHP Warning: PSPELL couldn't open the dictionary. reason: No word lists can be found for the language "en". in c:\inetpub\wwwroot\spell_checker\spell_checker.php on line 76 


Actual result:
--------------
!!PHP Warning: PSPELL couldn't open the dictionary. reason: No word lists can be found for the language "en". in c:\inetpub\wwwroot\spell_checker\spell_checker.php on line 76 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-04 13:02 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 10:01:26 2019 UTC