php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37299 CLI Segmentation fault on a Pentium III machine with tidy extension
Submitted: 2006-05-03 22:18 UTC Modified: 2006-05-13 01:00 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: volk at pcservice-direkt dot de Assigned:
Status: No Feedback Package: Tidy (PECL)
PHP Version: 5.1.3 OS: Linux 2.6.15-1-686
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-05-03 22:18 UTC] volk at pcservice-direkt dot de
Description:
------------
Since PHP 5.0.4 I get segmentation faults when the cli is shutting down. This occurs only on a Pentium III machine, not on machines with AMD's k7/k8 CPUs or Pentium P4 CPUs.
The ./configure --$OPTIONS are identical on all machines, beside the marchCFLAGS.
Yes, I've read the bugs #30660, #34725 and #36182, but there is not really a solution for this problem. This bug seems to be cpu specific.(?)

Reproduce code:
---------------
pvo@dahak:/usr/local/src/php-5.1.3-debug$ /tmp/sig11/bin/php -v

Expected result:
----------------
PHP 5.1.3 (cli) (built: May  3 2006 23:47:25) (DEBUG)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

Actual result:
--------------
PHP 5.1.3 (cli) (built: May  3 2006 23:47:25) (DEBUG)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
Segmentation fault

Backtrace:
 #0  0xb70589dd in ?? ()
 #1  0x0830957e in tsrm_shutdown () at /usr/local/src/php-5.1.3-debug/TSRM/TSRM.c:180
 #2  0x083f987e in main (argc=2, argv=0xbfa945b4) at /usr/local/src/php-5.1.3-debug/sapi/cli/php_cli.c:1255

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-04 13:52 UTC] tony2001@php.net
First of all: are you able to reproduce it without tidy?
If yes, why to mention it at all?
And honestly saying I don't understand what do you expect hear from us if it happens ONLY on this machine.
There must be something with your machine then.
 [2006-05-04 15:04 UTC] volk at pcservice-direkt dot de
I've adjusted config.nice and updated to PHP 5.1.4. Now it works:
pvo@dahak:~$ php -m | grep tidy
tidy
pvo@dahak:~$ 
(No segmentation fault)

If you are interested I can provide the difference between config.nice from PHP 5.1.3 and 5.1.4.
 [2006-05-05 19:10 UTC] mike@php.net
Please close the bug, if it does not occur anymore.
 [2006-05-11 10:57 UTC] RQuadling at GMail dot com
PHP V5.1.4 on Windows XP SP2.

With or without Zend Optimizer.
No extensions other than Tidy.

Crashes on close.

php -v

at the command line causes a "Report to Microsoft" / Dr. Watson thingy.
 [2006-05-11 11:04 UTC] RQuadling at GMail dot com
My hardware is Pentium 4 2.8GHz with 3GB RAM.
 [2006-05-11 11:18 UTC] RQuadling at GMail dot com
I have reverted back to PHP 5.1.3-dev (built: Feb 20 2006 00:29:25) and php -v is working and php -m shows the Tidy extension.

The Tidy extension was the only extension I've needed to toggle to have the problem with V5.1.4
 [2006-05-13 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 12:03:37 2021 UTC