php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37227 Error in build version
Submitted: 2006-04-27 20:59 UTC Modified: 2006-04-29 01:18 UTC
From: dsmith at prgrain dot bc dot ca Assigned:
Status: Not a bug Package: PDF related
PHP Version: 5.1.2 OS: Windows
Private report: No CVE-ID: None
 [2006-04-27 20:59 UTC] dsmith at prgrain dot bc dot ca
Description:
------------
Use the zipped distribution of PHP 5.1.2 for Wimdows, I have been able to get the core PHP active, but can not get the PDF functions to work.  If I enable the extensions PHP_PDF.DLL or PHP_CPDF.dll, I receive an error saying these versions were compiled with a different version, and PHP aborts.  I tried installing the PDFLIB Lite package, but the compiled DLL is not recognized as a valid PHP DLL when added to the list of extensions.

Is there newer version of these files, or perhaps an alternate installation?  

Actual result:
--------------
PHP Warning:  PHP Startup: SV?t$►W?=♦A☺☺Vhli☺☺j: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP    compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
 in Unknown on line 0
<br />
<b>Warning</b>:  PHP Startup: SV?t$&#9658;W?=&#9830;A&#9786;&#9786;Vhli&#9786;&#9786;j: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP    compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
 in <b>Unknown</b> on line <b>0</b><br />
PHP Warning:  PHP Startup: &#934;;&#9562;: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP    compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
 in Unknown on line 0
<br />
<b>Warning</b>:  PHP Startup: &#934;;&#9562;: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP    compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
 in <b>Unknown</b> on line <b>0</b><br />

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-27 21:02 UTC] dsmith at prgrain dot bc dot ca
Forgot to mention:  The version of the PHP_PDF.DLL files and PHP_CPDF.DLL files are the 5.1.2 versions that came with the extra PECL download.  They are dated January of 2006.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jan 17 23:01:24 2019 UTC