php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37192 cc fails on hash_adler.c:32
Submitted: 2006-04-25 08:22 UTC Modified: 2006-04-25 08:35 UTC
From: vincent dot castagnet at sgcib dot com Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.1.2 OS: Solaris 8
Private report: No CVE-ID:
 [2006-04-25 08:22 UTC] vincent dot castagnet at sgcib dot com
Description:
------------
Apache 2 installed, and Sybase 12.5 also.
Trying to compile PHP 5.1.2
The MAKE stop with error code 1:

cc: acomp failed for /home/mkdadm/php-5.1.2/ext/hash/hash_adler32.c
*** Error code 1
make: Fatal error: Command failed for target `ext/hash/hash_adler32.lo'


Reproduce code:
---------------
The configure:

./configure \
  --prefix=/usr/local/php \
  --with-sybase-ct=$SYBASE/$SYBASE_OCS \
  --enable-static=sybase-ct \
  --with-apxs2=/usr/local/apache2/bin/apxs \
  --with-gd \
  --with-zlib-dir=/usr/local \
  --enable-sysvmsg \
  --enable-sysvsem \
  --enable-sysvshm

Then:
make



Expected result:
----------------
I expect it would go along till the end and works ! :p

Actual result:
--------------
The error:

/bin/sh /home/mkdadm/php-5.1.2/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/hash/ -I/home/mkdadm/php-5.1.2/ext/hash/ -DPHP_ATOM_INC -I/home/mkdadm/php-5.1.2/include -I/home/mkdadm/php-5.1.2/main -I/home/mkdadm/php-5.1.2 -I/usr/local/include/libxml2 -I/usr/local/include -I/home/mkdadm/php-5.1.2/ext/date/lib -I/opt/nfs/sybase1251.solaris/OCS-12_5/include -I/home/mkdadm/php-5.1.2/TSRM -I/home/mkdadm/php-5.1.2/Zend  -D_POSIX_PTHREAD_SEMANTICS  -I/usr/local/include -g   -c /home/mkdadm/php-5.1.2/ext/hash/hash_adler32.c -o ext/hash/hash_adler32.lo
"/home/mkdadm/php-5.1.2/ext/hash/hash_adler32.c", line 32: non-constant initializer: op "&"
"/home/mkdadm/php-5.1.2/ext/hash/hash_adler32.c", line 32: non-constant initializer: op "&"
cc: acomp failed for /home/mkdadm/php-5.1.2/ext/hash/hash_adler32.c
*** Error code 1
make: Fatal error: Command failed for target `ext/hash/hash_adler32.lo'

When I go to:
ext/hash
I see:
hash_adler32.c
hash_adler32.loT

Obviously the .loT is wrong. SO what I did is rename the .loT in .lo, and then relaunch a "make".

This times it goes forward, but I am stopped by another error (which has no relation to this one because the same happens with PHP4).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-25 08:35 UTC] mike@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC