|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37162 WDDX module doesn't build non-bundled
Submitted: 2006-04-22 10:39 UTC Modified: 2006-04-23 16:02 UTC
From: jdolecek at NetBSD dot org Assigned:
Status: Closed Package: WDDX related
PHP Version: 5.1.2 OS: NetBSD
Private report: No CVE-ID:
 [2006-04-22 10:39 UTC] jdolecek at NetBSD dot org
When WDDX module is compiled separately from main PHP build, the module contents are not actually compiled due to #ifdef HAVE_WDDX. Since config.h is not included,HAVE_WDDX is not defined in this case and empty .o file is produced.

This problem also affects PHP 4.4.2.

Fix is to include config.h on top:

--- ext/wddx/wddx.c.orig        2006-04-22 12:18:32.000000000 +0200
+++ ext/wddx/wddx.c
@@ -20,2 +20,6 @@
+#include "config.h"
 #include "php.h"

Reproduce code:
Build as separate module (i.e. not compiled into php) and load via

Expected result:
Module loads

Actual result:
php prints warning when loading the extension:

PHP Warning:  Unknown(): Invalid library (maybe not a PHP library) ''  in Unknown on line 0


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-23 16:02 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Sun Oct 04 11:01:30 2015 UTC