php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37085 Unrecognized MySQL Libraries
Submitted: 2006-04-14 14:23 UTC Modified: 2006-04-14 14:27 UTC
From: rwjackson2006 at yahoo dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.1.3RC2 OS: Windows XP Professional
Private report: No CVE-ID: None
 [2006-04-14 14:23 UTC] rwjackson2006 at yahoo dot com
Description:
------------
When installing PHP 5.1.3 and MySQL on Apache on Windows XP, mysql functions are considered "undefined", even though there were no errors in installation and the extension was uncommented in the php.ini.

Reproduce code:
---------------
"Fatal error: Call to undefined function mysql_connect() in C:\Program Files\Apache Group\Apache2\htdocs"

Expected result:
----------------
Text displayed on the screen.  Simple test script.

Actual result:
--------------
Got the error "Fatal error: Call to undefined function mysql_connect() in C:\Program Files\Apache Group\Apache2\htdocs"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-14 14:27 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

http://php.net/mysql

Also, PHP needs access to the MySQL client library. A file named libmysql.dll is included in the Windows PHP distribution and in order for PHP to talk to MySQL this file needs to be available to the Windows systems PATH.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 03:05:53 2022 UTC