php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #37039 getenv('PHP_AUTH_USER') does not work
Submitted: 2006-04-11 13:08 UTC Modified: 2012-02-25 10:12 UTC
Votes:3
Avg. Score:3.3 ± 1.2
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:0 (0.0%)
From: php dot net at sebastianmendel dot de Assigned: rasmus (profile)
Status: Wont fix Package: *General Issues
PHP Version: * OS: *
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-04-11 13:08 UTC] php dot net at sebastianmendel dot de
Description:
------------
getenv('PHP_AUTH_USER') does not work

tested with 4.4.2 and 5.1.2 on Apache 2 on Windows

Reproduce code:
---------------
echo 'getenv(): ' . getenv('PHP_AUTH_USER') . "\n";
echo '$_SERVER: ' . $_SERVER['PHP_AUTH_USER'] . "\n";

Expected result:
----------------
getenv(): user
$_SERVER: user

Actual result:
--------------
getenv():
$_SERVER: user

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-11 13:54 UTC] sniper@php.net
Of course not, it's not an environment variable.
 [2006-04-11 14:08 UTC] php dot net at sebastianmendel dot de
but how do i access PHP_AUTH_USER or any other PHP_ variable with

variables_order = "GPC"

in php.ini?
 [2006-04-11 16:19 UTC] rasmus@php.net
You can't, which makes this a valid bug.
 [2010-12-20 14:15 UTC] jani@php.net
-Package: Feature/Change Request +Package: *General Issues -Operating System: Windows +Operating System: * -PHP Version: 5.1.2 +PHP Version: *
 [2012-02-25 10:12 UTC] rasmus@php.net
Outdated and not needed
 [2012-02-25 10:12 UTC] rasmus@php.net
-Status: Assigned +Status: Wont fix
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jun 13 06:01:23 2021 UTC