php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36888 Segmentation fault when references object incorrectly
Submitted: 2006-03-28 12:37 UTC Modified: 2006-03-29 10:25 UTC
From: bvghead at hotmail dot com Assigned:
Status: Closed Package: SimpleXML related
PHP Version: 5.1.2 OS: Red Hat AS4
Private report: No CVE-ID: None
 [2006-03-28 12:37 UTC] bvghead at hotmail dot com
Description:
------------
I am using simplexml_load_string
calling xml oject->childen();

echo xml element as array object

Segmentation fault


Reproduce code:
---------------
$xml_document2 =<<<EOT
<?xml version="1.0"?>
<merchant>
  <product>
    <productid>ISBN1845760832</productid>
  </product>
</merchant>
EOT;

$xml = simplexml_load_string($xml_document2);

$prod1 = $xml->children();
print_r($prod1);
echo $prod1['productid']; echo "\ndone.";


Expected result:
----------------
SimpleXMLElement Object
(
    [productid] => ISBN1845760832
)

done.

Actual result:
--------------
SimpleXMLElement Object
(
    [productid] => ISBN1845760832
)
Segmentation fault


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-28 13:02 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip

Can't reproduce.
 [2006-03-29 10:25 UTC] bvghead at hotmail dot com
Using the lastest snapshop I can't reproduce either.

Thanks.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 21:01:31 2024 UTC