php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36846 pdf_setcolor() claims `float c4' (7th parameter) when in RGB mode is not needed
Submitted: 2006-03-24 16:38 UTC Modified: 2006-03-26 01:04 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: matteo dot rinaudo at gmail dot com Assigned:
Status: Not a bug Package: PDF related
PHP Version: 4.4.2 OS: Fedora 1-PHP compil.from sources
Private report: No CVE-ID: None
 [2006-03-24 16:38 UTC] matteo dot rinaudo at gmail dot com
Description:
------------
We know that `pdf_setcolor()' currently accepts 7 parameters:

bool pdf_setcolor ( resource p, string fstype, string colorspace, float c1, float c2, float c3, float c4 )

If I pass 'rgb' as colorspace (3rd parameter), the function asks for `float c4' (7th parameter) which is not needed.
It seems that this bug reappeared *after* php-4.3.11.

Reproduce code:
---------------
pdf_setcolor($pdf, 'both', 'rgb', 0.7, 0.7, 0.7);

Expected result:
----------------
The code above does not work.

This code works:

pdf_setcolor($pdf, 'both', 'rgb', 0.7, 0.7, 0.7, 0.7);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-25 21:24 UTC] judas dot iscariote at gmail dot com
this is extension is no longer part of official PHP since 4.3.9

you should report this bug here :

http://pecl.php.net/bugs/report.php?package=pdflib

make sure you have the latest version.
 [2006-03-26 01:04 UTC] tony2001@php.net
Please report bugs in PECL packages to PECL bug system.
Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 21:01:27 2019 UTC