php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36838 segfault with unclosed dir on streamwrapper
Submitted: 2006-03-23 22:36 UTC Modified: 2006-03-28 12:45 UTC
From: theseer@php.net Assigned:
Status: Not a bug Package: Streams related
PHP Version: 5.1.2 OS: Linux
Private report: No CVE-ID: None
 [2006-03-23 22:36 UTC] theseer@php.net
Description:
------------
Running the reproduce code causes a segfault on shutdown when trying to call dir_closedir() of the stream wrapper class for the not-closed (commented out) closedir($dh).

While in this case it can easily be fixed by activly calling closedir(), it cannot if the SPL DirectoryIterator is used, which will cause a 2nd call to dir_closedir() with an invalid  handle (?) 



Reproduce code:
---------------
http://sandbox.freepoint.de/crash.phps

Expected result:
----------------
Normal shutdown

Actual result:
--------------
Segfault in shutdown process

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-28 12:45 UTC] mike@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Duplicate of bug #36320
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC