php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #36804 pdo_pgsql lobs problem
Submitted: 2006-03-20 20:13 UTC Modified: 2006-04-13 01:00 UTC
From: mauroi at digbang dot com Assigned:
Status: No Feedback Package: Documentation problem
PHP Version: 5.1.2 OS: Win XP SP2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-03-20 20:13 UTC] mauroi at digbang dot com
Description:
------------
I'm trying to insert a lob into a pgsql field.
My first problem is that the documentation doesn't say if the table field should be a bytea or an oid (more suitable for a large object). I supposed both worked.
I've tried with a bytea and it worked as expected. But the same operation with an OID field doesn't work. 
(Also, i've noticed three undocumented public methods in pdo_pgsql (pgsqlLOBUnlink, pgsqlLOBOpen, pgsqlLOBCreate))

Shouldn't it work with both methods???

At least, the quote function escapes always the lob as if it was a bytea. But in the rest of the driver it considers the possibility of an oid.

Thanks in advance.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-20 20:17 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2006-03-20 20:18 UTC] mauroi at digbang dot com
Duplicated. Sorry
 [2006-03-20 20:28 UTC] mauroi at digbang dot com
Well, at least it should be a documentation problem.
Maybe the appropiate note for the type of field that pdo_pgsql requires could be added.
As a matter of fact, I didn't know if this is a PHP bug or not, because the documentation doesn't say anything.
 [2006-04-03 18:04 UTC] vrana@php.net
> My first problem is that the documentation doesn't say if the table field should be a bytea or an oid

On which page should be mentioned this?
 [2006-04-03 18:39 UTC] mauroi at digbang dot com
Well, the page for the new method of pdo_pgsql (http://www.php.net/manual/en/function.pdo-pgsqllobcreate.php) could be. Just a note saying that "because the pdo driver only supports lobs using bytea fields, this function has been created". Or something like that (in a better english :) ).
I've also added some comments in that function that might be good to include in the documentation. But that's another story.

Thanks!
 [2006-04-05 16:25 UTC] vrana@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.


 [2006-04-13 01:00 UTC] phpdoc at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 14:01:29 2019 UTC