php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36787 connecting to remote oracle database
Submitted: 2006-03-19 12:43 UTC Modified: 2006-03-19 12:46 UTC
From: dasaradh at gmail dot com Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 5.1.2 OS: WNIDOWS XP SP2
Private report: No CVE-ID: None
 [2006-03-19 12:43 UTC] dasaradh at gmail dot com
Description:
------------
we have a problem in connecting to a remote oracle database,
we r using apache 2.0 and php 5.1.2 and we r getting error that data source name not found,we do not understand whether the problem is with apache or connectivity
our database is located at 192.168.1.228
database name is:nic
service name :ora
and our application is at 192.168.1.221

Reproduce code:
---------------
<?php
$link = odbc_connect('192.168.1.228:1521','nic', 'chandu', 'lal');
if (!$link) {
    die('Could not connect: ');
}
echo 'Connected successfully';
odbc_close($link);
?> 

Expected result:
----------------
connected successfu;;y

Actual result:
--------------
Warning: odbc_connect() [function.odbc-connect]: SQL error: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified, SQL state IM002 in SQLConnect in C:\Program Files\Apache Group\Apache2\htdocs\php\3.php on line 2
Could not connect:

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-19 12:46 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 10:01:25 2020 UTC