php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36757 Beheaviour of to in mail function different under windows than linux
Submitted: 2006-03-16 10:30 UTC Modified: 2006-03-16 10:33 UTC
From: pdejaeger at igepa dot be Assigned:
Status: Not a bug Package: Mail related
PHP Version: 5.1.2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
24 + 49 = ?
Subscribe to this entry?

 
 [2006-03-16 10:30 UTC] pdejaeger at igepa dot be
Description:
------------
I want to use the RFC 2822 standard in the to address

User <user@example.com>

But under windows this gives an error, under linux it works fine.

It seems to add it's own < and > characters under windows.


Reproduce code:
---------------
When I try this under windows :

mail("User <user@example.com>",$subject, "", $headers);

I get this error : 

Warning: mail() [function.mail]: SMTP server response: 501 Syntax error, parameters in command "RCPT TO:<User <user@example.com>>" unrecognized or missing in

It seems to add it's own <> characters !!??

If I run the same script under Linux it works fine !?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-16 10:33 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 02:03:41 2022 UTC