php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36695 microsoft word bug
Submitted: 2006-03-11 03:58 UTC Modified: 2007-06-04 10:22 UTC
From: vtsupermok at gmail dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.1.2 OS: window
Private report: No CVE-ID: None
 [2006-03-11 03:58 UTC] vtsupermok at gmail dot com
Description:
------------
Actually this bug is same with the bug #31327. 
http://bugs.php.net/bug.php?id=31327
Although the bug has been assigned to someone but sadly it haven't been solved for a long time. The developer beleieve it is caused by the setting of com.code_page and stop solve the bug. But I'm sure it isn't since I have try all the code page that micosoft word support. So I'm really hope someone can solve this problem. This problem has been exist from 4.x until now, in microsoft word only (Excel is normal) and english is normal but Chinese has problem


Reproduce code:
---------------
<?php

$code_page=array('950','0','1','2','3','65001');

for ($i=0;$i<count($code_page);$i++){
    // starting word
    $word = new COM("word.application",NULL,$code_page[$i]) or die("Unable to instantiate Word");
    echo "Loaded Word, version {$word->Version}\n";
    
    //bring it to front
    $word->Visible = 1;
    
    //open an empty document
    $word->Documents->Add();
    
    //do some weird stuff
    $word->Selection->TypeText("???Æ?");
   
    $path="D:\\AppServ\\www\\word\\".$i.".doc";
    echo $path."<br>";
    $word->Documents[1]->SaveAs($path);
    
    //closing word
    $word->Quit();
    
    //free the object
    $word = null;
} 
?>

Expected result:
----------------
???Æ?

Actual result:
--------------
???Æ?___

(there are 3 spaces or square after my words, but I use underline to represent it)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-11 10:07 UTC] mike@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe.
 [2006-03-11 14:29 UTC] vtsupermok at gmail dot com
I'm really sorry for any inconvenience to everyone but would you tell me that this problem is still under solving or has been stoped since the developer believe they have been solved the bug already? 

I will be very happy to see the problem is still under solving...because that mean the developer is believe that this is a bug.

I'm sure the problem is still here....pls checked...pls! I  have been waiting someone to solve this bug from version 4.x to 5.x..
 [2006-03-11 15:10 UTC] mike@php.net
We have very few developer resources for COM, so they'll be fixed occasionally.

Sorry
 [2007-06-04 09:27 UTC] vtsupermok at gmail dot com
Dear sir

the last post it said that "We have very few developer resources for COM, so they'll be fixed occasionally."

That mean the developer of php believe that it is a bug, right? But why the status of this bug is 'Bogus'

Pong
 [2007-06-04 09:36 UTC] tony2001@php.net
Because it's a duplicate of already existing report.
 [2007-06-04 10:22 UTC] vtsupermok at gmail dot com
Dear sir

Thank you for your attention. I am waiting someone to solve this bug starting from version 4.1.x, hope that it can be solved soon, thank you

Pong
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 06:05:53 2022 UTC