php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36643 error when i call execute method with param
Submitted: 2006-03-07 12:52 UTC Modified: 2006-03-07 12:59 UTC
From: alien at mosfasad dot ru Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.1.2 OS: WIN2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alien at mosfasad dot ru
New email:
PHP Version: OS:

 

 [2006-03-07 12:52 UTC] alien at mosfasad dot ru
Description:
------------
when i insert or update table with bind variable, i get bad result =(.
All values of bind variables change to last bind variable =(
___
If i use method bindParam apache crush =(
____
i take last cvs version of php, but not happened  =(
____
Windows 2000 SP4 (5.00.2195)
Apache/2.0.52 (Win32) PHP/5.1.3-dev
PDO drivers       sqlite2, sqlite, oci
OCI8              $Revision: 1.269.2.10 $
_____
php_pdo_oci8.dll - Oracle (OCI) driver for PDO(5.1.3.3)
_____

Reproduce code:
---------------
$oPdo = new PDO('oci:dbname=dinv','I3','XXXXXX');
$oStat = $oPdo->prepare("INSERT INTO REGISTRY (name, value) VALUES (?, ?)");
$oStat->execute(array('test1','test2'));

Expected result:
----------------
Table REGISTRY has new row with values:
--  | name  | value
1   |	test2 | test2

Actual result:
--------------
Table REGISTRY has new row with values:
--  | name  | value
1   |	test1 | test2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-03-07 12:59 UTC] tony2001@php.net
Duplicate of bug #36318.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 03:01:24 2021 UTC