php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #36636 Fatal, compiler and related errors return a HTTP status code of 200.
Submitted: 2006-03-06 20:33 UTC Modified: 2018-05-05 18:01 UTC
Votes:22
Avg. Score:4.7 ± 0.6
Reproduced:19 of 19 (100.0%)
Same Version:13 (68.4%)
Same OS:15 (78.9%)
From: jonnay at jonnay dot net Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.1.2 OS: Any
Private report: No CVE-ID: None
 [2006-03-06 20:33 UTC] jonnay at jonnay dot net
Description:
------------
When a script is executing, and an E_ERROR or an E_PARSE error occurs (and perhaps E_CORE_ERROR, E_COMPILE_ERROR), an HTTP status code of 500 should be sent (when possible), rather then a 200, because the server has in fact encountered an internal error, and everything is not actually OK.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-18 12:51 UTC] tyra3l at gmail dot com
this is implemented yet imho.
there is a bug with xdebug: http://bugs.php.net/bug.php?id=50921
 [2018-05-05 18:01 UTC] requinix@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 [2018-05-05 18:01 UTC] requinix@php.net
See bug #50921.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 16 07:01:27 2019 UTC