php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36534 Need for a search box in the downloadable HTML documentation
Submitted: 2006-02-26 11:13 UTC Modified: 2006-02-26 19:44 UTC
From: mathieu dot bonnet at nalkym dot org Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-02-26 11:13 UTC] mathieu dot bonnet at nalkym dot org
Description:
------------
It would be nice to have a simple search box in the PHP downloadable HTML documentation, at the top of the index page... (no need to have it on each page). It would redirect to the PHP website search results page.

(To avoid having an header too tall, the list of major contributors should be put on a single line (and the other informations should also be compressed). I guess the user may use stylesheets to modify this, but I do not see any need to have an header that tall.)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-26 11:17 UTC] mathieu dot bonnet at nalkym dot org
Something like this:

########################################

<form action="http://www.php.net/search.php" method="post">
  <fieldset>
    <legend>Search PHP online documentation, website and mailing lists</legend>
    <label><b>Search keywords</b>:
      <input type="text" name="pattern" value="" size="30" accesskey="s" />
    </label>
    <label><b>Source</b>:
      <select name="show">
        <option value="quickref" selected="selected">PHP function list</option>
        <option value="manual">Whole PHP online documentation</option>
        <option value="wholesite">Whole PHP website</option>
        <option value="bugdb">PHP bug database</option>
        <option value="maillist">PHP general mailing list</option>
        <option value="devlist">PHP developer mailing list</option>
        <option value="phpdoc">PHP documentation mailing list </option>
      </select>
    </label>
    <button type="submit">Search online</button>
  </fieldset>
</form>

########################################
 [2006-02-26 11:30 UTC] mathieu dot bonnet at nalkym dot org
(corrected the summary... sorry, Firefox password remembering problem -it remembered the summary and exchanged it...)
 [2006-02-26 14:09 UTC] mathieu dot bonnet at nalkym dot org
As said in bug #36533, I don't think LiveDocs is the solution, for now.
 [2006-02-26 17:16 UTC] sean@php.net
If what we provide isn't good enough for you, feel free to build your own:
http://doc.php.net/php/dochowto/part-generating-output.php

Each generation run can take several hours (thus, livedocs).

S

 [2006-02-26 18:19 UTC] mathieu dot bonnet at nalkym dot org
>
> If what we provide isn't good enough for you, feel free to
> build your own:
> http://doc.php.net/php/dochowto/part-generating-output.php
>

If I felt I was the only one to need a simple search box, or the user notes (see bug #36533), in an easily and officialy downloadable PHP HTML documentation, I would not have reported it as "website problems"...

I reported the need for a search box, because I feel it might be useful to people using the PHP downloadable HTML documentation...

If you feel it is not a global need, then it's ok, I'll just edit my own download, to add this search box, and readd it every time I download a new update...

You might, for example, consider the user should better configure and use its browser search box feature (if available), and it is already documented in the "Quick Reference Tips" page...

For the users who use this feature, having another search box in the offline manual pages might be redundant, so you might indeed not add it...

As far as I'm concerned, I prefer a search box inside the manual, because the browser header (and the browser search box) if too far from the center of my screen... (and my field of vision). It's easier and quicker to type something in a search box inside the manual page, rather than outside my standard field of vision.

I posted this report, because I felt it might be the case for most people... (more or less unconsciously)

Now, again, if you don't think it is (and feel redundancy is bad or not worth in this case), then I will not insist.
 [2006-02-26 19:44 UTC] goba@php.net
Mathieu, my position on this is that it is probably a general need, shared among several PHP documentation readers. Some are very happy with the browser search box feature (which searches in and gives results for the online version!). 

Putting a search box into the static HTML downloads is misleading in that it does search in the online version (isn't it the whole point of the offline version to not direct you to the online one?).

Because we see the general need for a truly offline working searchbox and user notes, we started to develop a solution. It is a reasonable requirement for a PHP developer to have a local server, so we see that this is not a problem. Currently the problem is that it is not easy to find testers, because some people insist that we should put time into technology we clearly intend to replace with a better one. Our time is limited. Let us put time into what is going to be better.

Until then, CTRL+K immeditely moves your cursor to the search box in Firefox, and any other browser you use will probably have a similar key combination. You don't need to use your mouse to point there.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 12:01:25 2019 UTC