php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36516 Sybase library names have changed in Sybase 15.x
Submitted: 2006-02-24 18:22 UTC Modified: 2008-11-10 10:53 UTC
Votes:4
Avg. Score:4.5 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: sean at digitalworkshop dot net Assigned:
Status: Not a bug Package: Sybase-ct (ctlib) related
PHP Version: 5.1.2 OS: Solaris 10
Private report: No CVE-ID: None
 [2006-02-24 18:22 UTC] sean at digitalworkshop dot net
Description:
------------
In the new 15.x release of Sybase ASE, they have changed the names of the client library files which the PHP extension links to.

Up to and including Sybase ASE 12.5.x, these were:

-lcs -lct -lcomn -lintl

But now they are:

-lsybcs -lsybct -lsybcomn -lsybintl


This affects the following files in the PHP build:

./configure
./ext/sybase_ct/config.m4

I have patched the config scripts and successfully built/tested PHP with ASE 15.0 sybase_ct support. I'll attach patch files to this ticket for someone to play with ... the config scripts will need to me modified to check for which version of client library is present and set up the link arguments accordingly. I'll try to help out here if I manage to get some time to work on it!




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-24 18:33 UTC] sean at digitalworkshop dot net
Guys, if you can tell me where to upload files to, I'll happily provide patches to work around the changed library names. I thought I could attach them to this ticket but can't see how right now.
 [2006-02-24 18:37 UTC] tony2001@php.net
Put them somewhere in the net.
 [2006-04-12 17:06 UTC] sniper@php.net
Or send the config.m4 you have to me: sniper@php.net
and I'll see if it's usable. (do NOT send the configure file or diff of it :)
 [2006-10-08 00:28 UTC] jmherod at sbcglobal dot net
Same problem exists for Sybase 12.5.3 under MacOSX 10.4.7. 

There is an additional library in the MacOSX Sybase distribution (-lsybsrv) that must be included in the liblist for the build to succeed.
 [2008-11-10 10:53 UTC] thekid@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Duplicate of Bug #45357 - as stated there: Please see if
http://sitten-polizei.de/php/sybase-configm4.diff 
works for you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 18:01:29 2020 UTC