php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36509 phpize error
Submitted: 2006-02-24 10:36 UTC Modified: 2006-03-19 18:20 UTC
From: cristic at interaktonline dot com Assigned:
Status: Wont fix Package: Unknown/Other Function
PHP Version: 5.1.2 OS: Linux Fedora Core 4
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-02-24 10:36 UTC] cristic at interaktonline dot com
Description:
------------
When the automake and autoconf miss from the machine the phpize output
will display:

Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
/usr/bin/phpize: line 105: aclocal: command not found

instead of making an initial check of these tools installed on machine
and to throw the appropriate error message.

Fixed after installing the automake.

This was originally reported to the PECL and redirected here: http://pecl.php.net/bugs/bug.php?id=5575


Reproduce code:
---------------
[root@linux APC-3.0.8]# phpize

Expected result:
----------------
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
Automake missing => minimal version required x.x.x

Actual result:
--------------
/usr/bin/phpize: line 105: aclocal: command not found

which is kind of cryptic


I just tried to point this so future users having this problem to not have to start doing a big research and to improve the PHP feel. It is a small issue but normally I expect to see what is expected things from the machine and what is the actual found results in a less computer binary machine language.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-24 14:02 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2006-03-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-03-15 11:25 UTC] cristic at interaktonline dot com
I can't redo a test as I've installed the needed dependencies packages. If you say that the problem is fixed I believe you.
 [2006-03-19 18:20 UTC] mike@php.net
Jani is not around, so most probably nobody is going to improve this.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 26 10:01:25 2019 UTC