php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36332 Memory leaks using phpMyAdmin 2.8.0-beta1
Submitted: 2006-02-08 09:22 UTC Modified: 2006-02-08 10:43 UTC
From: Bjorn dot Wiberg at its dot uu dot se Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.1.2 OS: AIX 5.2 ML5, Linux 2.6.14.3
Private report: No CVE-ID: None
 [2006-02-08 09:22 UTC] Bjorn dot Wiberg at its dot uu dot se
Description:
------------
The Apache error log lists memory leaks when using phpMyAdmin 2.8.0-beta1 on Apache 2.0.55 with PHP as SAPI. I'm wondering whether these memory leaks are due to something wrong with PHP, or something wrong with phpMyAdmin?

It would be interesting to know if you encounter the same problem on another machine, with --enable-debug and report_memleaks on?

phpMyAdmin bug report: https://sourceforge.net/tracker/?func=detail&atid=377408&aid=1418607&group_id=23067

phpMyAdmin download page:
http://www.phpmyadmin.net/home_page/downloads.php

Many thanks in advance!

Best regards,
Bj?rn

Reproduce code:
---------------
Using phpMyAdmin, visiting the index page, browsing around (the CSS stuff gets included just about everywhere).

Expected result:
----------------
No memleaks reported.

Actual result:
--------------
From the Apache error log:

---8<---
[Mon Feb  6 15:00:01 2006]  Script:  '/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x31FB153C (28 bytes), script=/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
[Mon Feb  6 15:00:01 2006]  Script:  '/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x31FB0C8C (16 bytes), script=/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php
=== Total 2 memory leaks detected ===
[Mon Feb  6 14:59:55 2006]  Script:  '/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x31FE62DC (28 bytes), script=/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
[Mon Feb  6 14:59:55 2006]  Script:  '/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x31FE601C (16 bytes), script=/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php
=== Total 2 memory leaks detected ===
[Mon Feb  6 15:00:10 2006]  Script:  '/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x31FB5AFC (28 bytes), script=/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
[Mon Feb  6 15:00:10 2006]  Script:  '/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x31FB583C (16 bytes), script=/apache/htdocs/hotel/phpmyadmin/css/phpmyadmin.css.php
=== Total 2 memory leaks detected ===
--->8---

(I get a lot of these in the error log.)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-08 09:37 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.
 [2006-02-08 10:39 UTC] Bjorn dot Wiberg at its dot uu dot se
I'm not sure if you can spot something from the .css.php file, but here it is:

http://www.anst.uu.se/bwiberg/php/phpmyadmin.css.php.phps

I also tried this on a Linux box (Debian Sarge):

root@coturnix:~# uname -a
Linux coturnix 2.6.14.3.051125-01-dell-custom #1 SMP Fri Nov 25 18:39:01 CET 2005 i686 GNU/Linux

Same result, after reloading the phpMyAdmin index page a couple of times (it does not happen all the time!):

---8<---
[Wed Feb  8 10:33:19 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x083C12EC (16 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
[Wed Feb  8 10:33:19 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x083C1284 (28 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
=== Total 2 memory leaks detected ===
[Wed Feb  8 10:33:32 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x084F108C (16 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
Last leak repeated 1 time
[Wed Feb  8 10:33:32 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x084F1024 (28 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
Last leak repeated 1 time
=== Total 4 memory leaks detected ===
[Wed Feb  8 10:33:35 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x084F13CC (16 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
Last leak repeated 1 time
[Wed Feb  8 10:33:35 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x084F1364 (28 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
Last leak repeated 1 time
=== Total 4 memory leaks detected ===
[Wed Feb  8 10:33:39 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x083BCCE4 (16 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
Last leak repeated 1 time
[Wed Feb  8 10:33:39 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x083BCC7C (28 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
Last leak repeated 1 time
=== Total 4 memory leaks detected ===
[Wed Feb  8 10:33:43 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/main/php_variables.c(186) :  Freeing 0x083C11A4 (16 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
Last leak repeated 1 time
[Wed Feb  8 10:33:43 2006]  Script:  '/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php'
/usr/local/src/php-5.1.2/ext/standard/string.c(3006) :  Freeing 0x083C113C (28 bytes), script=/var/www/support.student.uu.se/admin/phpmyadmin/css/phpmyadmin.css.php
/usr/local/src/php-5.1.2/Zend/zend_alloc.c(237) : Actual location (location was relayed)
Last leak repeated 1 time
=== Total 4 memory leaks detected ===
--->8---

PHP configure line is:

---8<---
./configure --enable-bcmath --enable-calendar --enable-dba --enable-dbase --enable-debug --enable-exif --enable-embedded-mysqli --enable-filepro --enable-ftp --enable-gd-jis-conv --enable-gd-native-ttf --enable-mb
string --enable-memory-limit --enable-shmop --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-zend-multibyte --with-apxs2=/usr/bin/apxs2 --with-bz2 --with-db4 --with-gd --with-gdbm --with-gettext --with-inifile --with-jpeg-dir --with-ldap --with-libxml-dir --with-mime-magic --with-mysql=/usr/local/mysql --with-openssl --with-png-dir --with-tiff-dir --with-ttf --with-zlib --with-zlib-dir
--->8---

Best regards,
Bj?rn
 [2006-02-08 10:43 UTC] derick@php.net
Sorry, but we're *not* going to debug phpMyAdmin for you. It simply looks like it's doing some circular references with objects or something. No big deal.

If you have a *short* script that you can prove it shouldn't leak feel free to open this. Otherwise leave this bug's status set to "bogus".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 13:01:23 2019 UTC