php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36276 Tiger hash fails regression test
Submitted: 2006-02-03 18:02 UTC Modified: 2010-12-20 12:00 UTC
From: shiloh dot heurich at newvillagemedia dot com Assigned:
Status: Not a bug Package: hash related
PHP Version: 5CVS-2006-02-03 (snap) OS: Mac OS X 10.4.4
Private report: No CVE-ID: None
 [2006-02-03 18:02 UTC] shiloh dot heurich at newvillagemedia dot com
Description:
------------
When running regression tests on PHP 5.1.2 and 200602031530 
snapshots, tiger hash function fails:

FAIL tiger [ext/hash/tests/tiger.phpt] t]

uname: Darwin 8.4.0 Darwin Kernel Version 8.4.0: Tue Jan  3 
18:22:10 PST 2006; root:xnu-792.6.56.obj~1/RELEASE_PPC Power 
Macintosh powerpc

gcc: gcc version 4.0.1 (Apple Computer, Inc. build 5250)

configuration: CFLAGS='-g -O2 -arch ppc -mcpu=970' ./
configure  --prefix=/usr/local/php5 --mandir=/usr/local/
php5/share/man --infodir=/usr/local/php5/share/info --
sysconfdir=/usr/local/etc/php5 --x-includes=/usr/X11R6/
include --x-libraries=/usr/X11R6/lib --with-apxs=/usr/sbin/
apxs --enable-cli --enable-cgi --with-layout=PHP --with-
config-file-path=/usr/local/etc/php5 --enable-ipv6 --
disable-all --enable-libxml --with-libxml-dir=/usr --with-
openssl=/usr --with-kerberos=/usr --with-pcre-regex=/usr/
local/pcre --with-zlib=/usr --with-zlib-dir=/usr --enable-
bcmath --with-bz2=/usr --enable-calendar --enable-ctype --
with-curl=/usr --enable-dba --with-cdb --with-inifile --
with-flatfile --enable-dom --enable-exif --enable-ftp --
with-openssl-dir=/usr --with-gd --with-jpeg-dir=/usr/local/
libjpeg --with-png-dir=/usr/local/libpng --with-xpm-dir=/
usr/X11R6 --with-freetype-dir=/usr/X11R6 --with-t1lib=/usr/
local/t1lib --enable-gd-native-ttf --enable-hash --with-
imap=/usr/local/imap-2004g --with-imap-ssl=/usr --with-
ldap=/usr --enable-mbstring --enable-mbregex --with-mcrypt=/
usr/local/libmcrypt --with-mssql=/usr/local/freetds --with-
mysql=/usr --with-mysql-sock=/var/mysql/mysql.sock --with-
mysqli=/usr/bin/mysql_config --with-ncurses=/usr --with-
iodbc=/usr --enable-pdo --with-pdo-dblib=/usr/local/freetds 
--with-pdo-mysql=/usr --enable-posix --with-pspell=/usr/
local/aspell --enable-reflection --enable-session --enable-
shmop --enable-simplexml --with-snmp=/usr --enable-soap --
enable-sockets --enable-spl --with-sqlite --enable-sqlite-
utf8 --enable-sysvmsg --enable-sysvsem --enable-sysvshm --
with-tidy=/usr/local/tidy --enable-tokenizer --enable-wddx 
--enable-xml --enable-xmlreader --with-xmlrpc --with-iconv=/
usr/local/libiconv --with-iconv-dir=/usr/local/libiconv --
enable-xmlwriter --with-xsl=/usr --with-pear --enable-
memory-limit


Reproduce code:
---------------
tiger.php:

<?php
echo hash('tiger192,3', ''),"\n";
echo hash('tiger192,3', 'abc'),"\n";
echo hash('tiger192,3', str_repeat('a', 63)),"\n";
echo hash('tiger192,3', str_repeat('abc', 61)),"\n";
echo hash('tiger192,3', str_repeat('abc', 64)),"\n";
?>


Expected result:
----------------
tiger.log:

---- EXPECTED OUTPUT
24f0130c63ac933216166e76b1bb925ff373de2d49584e7a
f258c1e88414ab2a527ab541ffc5b8bf935f7b951c132951
8ee409a14e6066933b63d5b2abca63d71a78f55e29eb4649
2586156d16bf9ab1e6e48bdf5e038f8053c30e071db3bcb0
3ee8a9405396ddba1bc038508af4164ac1fe59ef58916a85


Actual result:
--------------
tiger.log:

---- ACTUAL OUTPUT
60ef6c0dbc077b9c175ffb7771008c253bacea024c9d01ab
c79e799e14b53e7df935d83477fa4df939d18c44f76b73cd
0cbefecf310004da41a290cfeef81e918ea533f130c2b9ba
11fe76694d6a116bd7af6eeded0ef4d147e43ee107abda06
397fb45a4406fd2046c9ad070907ac574d004836c89553a2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-04 21:41 UTC] nlopess@php.net
duplicate of http://pecl.php.net/bugs/6391
 [2010-12-20 12:00 UTC] jani@php.net
-Package: Tidy +Package: hash related
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Nov 26 23:03:13 2021 UTC