php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36201 configure fails to find default Slackware installation of apache
Submitted: 2006-01-30 01:01 UTC Modified: 2006-01-30 16:46 UTC
From: jayc dot lawrence at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.2 OS: Slackware 10.2 / Linux 2.4.31
Private report: No CVE-ID: None
 [2006-01-30 01:01 UTC] jayc dot lawrence at gmail dot com
Description:
------------
May have to reinstall Apache on a Slackware installation in order to configure PHP.

Basically, even if i just do a ./configure --with-apache it wont find the apache path. 

Apache is running fine, the configure complains about not being able to locate the file http.d in /usr/local/apache/

Reproduce..

Reproduce code:
---------------
Ok.. so i do the following

root@xxx:/home/xxx/php-5.1.2#locate httpd.h

/var/www/htdocs/manual/programs/httpd.html.ja.jis
/var/www/htdocs/manual/programs/httpd.html.html
/var/www/htdocs/manual/programs/httpd.html.en
/var/www/htdocs/php/manual_en/install.fhttpd.html
/var/www/htdocs/php/manual_en/install.omnihttpd.html
/var/www/htdocs/php/manual_en/install.otherhttpd.html
/var/www/htdocs/php/manual_en/install.unix.fhttpd.html
/var/www/htdocs/php/manual_en/install.windows.omnihttpd.html
/usr/src/linux-2.4.31/include/config/khttpd.h
/usr/include/apache/httpd.h  <-- * here *

So, i try ./configure --with-apache=/usr/include/apache/



Expected result:
----------------
I expected it to compile. Maybe i am making a beginners mistake, as i havent been using linux for very long, but i have searched on Google already for answers, to no avail.


Actual result:
--------------
root@xxx:/home/xxx/php-5.1.2# ./configure --with-apache=/usr/include/apache/
loading cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for egrep... grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking whether ln -s works... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for re2c... no
configure: warning: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for bison... bison -y
checking for bison version... 1.35 (ok)
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for working const... yes
checking for flex version... 2.5.4 (ok)
checking whether to force non-PIC code in shared modules... yes
checking for pthreads_cflags... -pthread
checking for pthreads_lib...

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
configure: error: Invalid Apache directory - unable to find httpd.h under /usr/include/apache/


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-30 04:52 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

RTFM, and perhaps actually reading the INSTALL file might help too? Definately not a bug.
 [2006-01-30 16:46 UTC] jayc dot lawrence at gmail dot com
I have RTFM as you quite politely put it.
Thank you for your time!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Sep 26 23:05:52 2022 UTC